Bug 868301 - [CLI] provider status field "Last Sync" not translated
[CLI] provider status field "Last Sync" not translated
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Localization and Internationalization (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-19 08:52 EDT by Garik Khachikyan
Modified: 2015-01-04 16:59 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-16 09:23:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Garik Khachikyan 2012-10-19 08:52:31 EDT
Description of problem:
switching to the LANG=de_DE does not bring translated the output of "Red Hat" provider status field of: "Last Sync".
`kk provider status --name "Red Hat" --org ACME_Corporation`
---
Id:          1
Name:        Red Hat
Last Sync:   never
Sync State:  Nicht synchronisiert

Version-Release number of selected component (if applicable):
katello-cli-1.1.8-7.el6cf.noarch
katello-1.1.12-16.el6cf.noarch

How reproducible:
always using CLI

Steps to Reproduce:
1. on cli execute above
2.
3.
  
Actual results:
word "never" in "Last Sync"

Expected results:
"never" to get translated

Additional info:
Comment 2 Garik Khachikyan 2012-10-19 08:58:51 EDT
not a major thing, but it is a translation issue - and easy to verify in case we would be able to get another translation round.
Comment 3 Garik Khachikyan 2012-10-22 06:50:29 EDT
# COMMENT

some more translations please:

repo enable|disable


---
cmd:
LANG=de_DE && katello -uadmin -padmin repo enable --name "Red Hat Enterprise Linux 6 Server RPMs x86_64 6Server" --product "Red Hat Enterprise Linux Server"
output:
Repository 'Red Hat Enterprise Linux 6 Server RPMs x86_64 6Server' enabled.
---
Comment 4 Garik Khachikyan 2012-10-22 09:26:47 EDT
please disregard my comment#3

was checking on katello. SE is fine :)
Comment 6 Bryan Kearney 2013-12-16 09:23:33 EST
Closing all i18n bus due to ne architecture. The goal is still a localized UI and CLI, but we will do this via a new round of testing.

Note You need to log in before you can comment on or make changes to this bug.