Bug 868302 - Dolphin doesn't honor the Default Applications terminal settings
Dolphin doesn't honor the Default Applications terminal settings
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kde-baseapps (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: beta
: ---
Assigned To: Jan Grulich
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-19 08:55 EDT by Vitezslav Humpa
Modified: 2013-08-08 03:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-08 03:35:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vitezslav Humpa 2012-10-19 08:55:21 EDT
Description of problem:
The 'Open Terminal Here' service of dolphin doesn't honor the default terminal set in the Default Applications module of systemsettings. Konsole seems to be hardcoded there.

Version-Release number of selected component (if applicable):
dolphin = 4.9.2-2.el7

How reproducible:
Always

Steps to Reproduce:
1. Set i.e. xterm to be a default terminal emulator in the Default Applications
2. Open Dolphin
3. Right-click somewhere and choose Actions->Open Terminal Here
  
Actual results:
Konsole opens

Expected results:
xterm opens
Comment 1 Jan Grulich 2012-10-25 07:23:49 EDT
This is because Dolphin uses for this konsolehere.desktop file. If you want to open xterm like you described, you will have to create similar .desktop file and put it into /usr/share/kde4/services/ServiceMenus/.
Comment 2 Vitezslav Humpa 2012-10-25 07:58:11 EDT
Something that perhaps SystemSettings should have done in this scenario?
Comment 3 Jan Grulich 2012-10-25 08:20:04 EDT
This is the responsibility of the applications. They have described services in .desktop files and Dolphin then collects all these services and uses them. Like Konsole which installs mentioned .desktop file which Dolphin uses. It's not dependent on system settings.

Note You need to log in before you can comment on or make changes to this bug.