Bug 868304 - UserVmManager of a VM is not able to see its permissions in REST API
UserVmManager of a VM is not able to see its permissions in REST API
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-restapi (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Oved Ourfali
Ondra Machacek
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-19 08:57 EDT by David Jaša
Modified: 2016-02-10 14:05 EST (History)
8 users (show)

See Also:
Fixed In Version: si22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 14:59:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jaša 2012-10-19 08:57:28 EDT
Description of problem:
UserVmManager of a VM is not able to see its permissions in REST API. She is able to see permissions in User Portal just fine

Version-Release number of selected component (if applicable):
3.1.0-18 / si19.1

How reproducible:


Steps to Reproduce:
1. issue a filtered GET query on VM permissions:
curl ...  -H "filter: true" -X GET https://rhevm31.example.com/api/vms/ad5f7497-120d-40da-9093-c9c4b8919e50/permissions
  
Actual results:
HTTP/1.1 400 Bad Request
Date: Fri, 19 Oct 2012 12:52:58 GMT
Content-Type: application/xml
Content-Length: 188
Connection: close

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<fault>
    <reason>Operation Failed</reason>
    <detail>query execution failed due to insufficient permissions.</detail>
</fault>

Expected results:
user is able to to see the permissions the same way as in the User Portal

Additional info:
other VM subcollections are visible just fine (apart from tags that are admin-only anyway)
Comment 1 Oved Ourfali 2012-10-22 07:58:54 EDT
Gerrit patch: 
http://gerrit.ovirt.org/#/c/8720/
Comment 2 Oved Ourfali 2012-10-22 08:30:15 EDT
Commit: 9254ec57d533a0694e7ef8817b95e44782c4e349

http://gerrit.ovirt.org/gitweb?p=ovirt-engine.git;a=commit;h=9254ec57d533a0694e7ef8817b95e44782c4e349

Note You need to log in before you can comment on or make changes to this bug.