Bug 868305 - iscsi-initiator is not able to discovery target
Summary: iscsi-initiator is not able to discovery target
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: iscsi-initiator-utils
Version: 6.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Chris Leech
QA Contact: Bruno Goncalves
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-10-19 13:05 UTC by Bruno Goncalves
Modified: 2013-02-21 10:32 UTC (History)
4 users (show)

Fixed In Version: 6.2.0.873-2.el6
Doc Type: Bug Fix
Doc Text:
Cause: Regression in iscsiuio 0.7.4.3 update Consequence: iSCSI discovery and login fail on certain hardware Fix: Fix was part of iscsiuio 0.7.6.1 update Result: iSCSI is functional again
Clone Of:
Environment:
Last Closed: 2013-02-21 10:32:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0438 normal SHIPPED_LIVE iscsi-initiator-utils bug fix and enhancement update 2013-02-20 20:48:28 UTC

Description Bruno Goncalves 2012-10-19 13:05:31 UTC
Description of problem:
The newer version of iscsi-initiator-utils is not able to discovery target portals.

It works fine with: iscsi-initiator-utils.x86_64 0:6.2.0.872-41.el6


iscsiadm -m discovery -I bnx2i.00:10:18:88:e7:ff -I bnx2i.00:10:18:88:e7:fd -p na3170b.lab.bos.redhat.com -t st
iscsiadm: Could not set host net params (err 29)

iscsiadm: Connection to discovery portal 10.16.41.222 failed: internal error
iscsiadm: Could not set host net params (err 29)

iscsiadm: Connection to discovery portal 10.16.41.222 failed: internal error
iscsiadm: Could not set host net params (err 29)

iscsiadm: Connection to discovery portal 10.16.41.222 failed: internal error
iscsiadm: Could not set host net params (err 29)

iscsiadm: Connection to discovery portal 10.16.41.222 failed: internal error
iscsiadm: Could not set host net params (err 29)

iscsiadm: Connection to discovery portal 10.16.41.222 failed: internal error
iscsiadm: Could not set host net params (err 29)

iscsiadm: Connection to discovery portal 10.16.41.222 failed: internal error
iscsiadm: connection login retries (reopen_max) 5 exceeded
iscsiadm: Could not perform SendTargets discovery: internal error


Version-Release number of selected component (if applicable):
iscsi-initiator-utils 6.2.0.873-1.el6

How reproducible:
100%

Steps to Reproduce:
1.Configure the interfaces to use DHCP
iscsiadm -m iface -I bnx2i.00:10:18:88:e7:ff -o update -n iface.ipaddress -v 0.0.0.0
bnx2i.00:10:18:88:e7:ff updated.
iscsiadm -m iface -I bnx2i.00:10:18:88:e7:fd -o update -n iface.ipaddress -v 0.0.0.0
bnx2i.00:10:18:88:e7:fd updated.

2. Try to discovery portal
iscsiadm -m discovery -I bnx2i.00:10:18:88:e7:ff -I bnx2i.00:10:18:88:e7:fd -p na3170b.lab.bos.redhat.com -t st
3.
  
Actual results:
Discovery fails

Expected results:

iscsiadm -m discovery -I bnx2i.00:10:18:88:e7:ff -I bnx2i.00:10:18:88:e7:fd -p na3170b.lab.bos.redhat.com -t st
[  OK  ] iscsid: [  OK  ]
iscsiadm: Could not set host net params (err 29)

iscsiadm: Connection to discovery portal 10.16.41.222 failed: internal error
iscsiadm: Could not set host net params (err 29)

iscsiadm: Connection to discovery portal 10.16.41.222 failed: internal error
iscsiadm: Could not set host net params (err 29)

iscsiadm: Connection to discovery portal 10.16.41.222 failed: internal error
iscsiadm: Could not set host net params (err 29)

iscsiadm: Connection to discovery portal 10.16.41.222 failed: internal error
10.16.41.222:3260,1 iqn.1992-08.com.netapp:sn.151753773
10.16.43.127:3260,1 iqn.1992-08.com.netapp:sn.151753773
10.16.41.222:3260,1 iqn.1992-08.com.netapp:sn.151753773
10.16.43.127:3260,1 iqn.1992-08.com.netapp:sn.151753773


Additional info:
An error message appears when listing the ifaces for the first time.
iscsiadm -m iface
iscsiadm: Could not scan /sys/class/iscsi_transport.
default tcp,<empty>,<empty>,<empty>,<empty>
iser iser,<empty>,<empty>,<empty>,<empty>
bnx2i.00:10:18:88:e7:fd bnx2i,00:10:18:88:e7:fd,0.0.0.0,<empty>,<empty>
bnx2i.00:00:00:00:00:00 bnx2i,00:00:00:00:00:00,<empty>,<empty>,<empty>
bnx2i.00:10:18:88:e7:ff bnx2i,00:10:18:88:e7:ff,0.0.0.0,<empty>,<empty>

Comment 2 Eddie Wai 2012-10-22 18:40:05 UTC
(In reply to comment #0)
> Description of problem:
> The newer version of iscsi-initiator-utils is not able to discovery target
> portals.
> 
> It works fine with: iscsi-initiator-utils.x86_64 0:6.2.0.872-41.el6
> 
> 
This was caused by an IPv4 DHCP bug inside the iscsiuio-0.7.4.3 patchset.  The fix was already uploaded as part of a bigger update from iscsiuio-0.7.4.3 to iscsiuio-0.7.6.1.

Comment 4 edwardn 2012-10-22 22:38:04 UTC
Verified discovery and login over DHCP using iscsi-initiator-utils-6.2.0.873-2.el6.x86_64.rpm.  873-1 had problems.

Comment 5 Bruno Goncalves 2012-10-24 06:57:23 UTC
Verified problem has been fixed on iscsi-initiator-utils-6.2.0.873-2.el6.x86_64

Comment 7 errata-xmlrpc 2013-02-21 10:32:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0438.html


Note You need to log in before you can comment on or make changes to this bug.