Bug 868338 - Win7 32bit client, USB Redirection error dialog pops up, after selecting a USB device from menu options
Win7 32bit client, USB Redirection error dialog pops up, after selecting a US...
Status: CLOSED DUPLICATE of bug 842816
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mingw-virt-viewer (Show other bugs)
3.1.0
i386 Windows
unspecified Severity medium
: ---
: 3.3.0
Assigned To: Uri Lublin
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-19 10:27 EDT by Vimal Patel
Modified: 2015-09-22 09 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 09:14:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vimal Patel 2012-10-19 10:27:32 EDT
Description of problem:
USB redirection works properly if USB auto-share is on.

If USB auto-share is off, after user goes File -> USB device selection, and selects the device,  I see the USB redirection error, but then the USB device can still be seen by the guest. (With firewall on or off)

Version-Release number of selected component (if applicable):
Client: Win7 32bit (From RHEVM3.1 si20)
remote-viewer: 0.5.3
USB Clerk

Guest: RHEL 6.3 64
rhevm-guest-agent-1.0.5-3.el6ev.x86_64
spice-vdagent-0.8.1-3.el6.x86_64
xorg-x11-drv-qxl-0.0.14-13.el6_2.x86_6

How reproducible:
100%

Steps to Reproduce:
1.  Go to the UserPortal.
2.  Uncheck USB Auto-Share option 
3.  Connect to the console of the VM
4.  Select File->USB device selection -> select USB device
  
Actual results:
An error dialog pops up.
However the USB device is still seen on the guest and can be used w/o errors.

Expected results:
USB Device is seen on the guest and can be used w/o errors.

Additional info:
Comment 1 Andrew Cathrow 2013-02-19 17:37:34 EST
will review for 3.2.z
Comment 3 Marc-Andre Lureau 2013-07-22 10:53:56 EDT
Please Uri or Arnon, have a look. thanks
Comment 4 Uri Lublin 2013-07-22 12:59:34 EDT
This bug seems similar to bug 842816

Does this problem still occurs with updated build ?
  rhevm-spice-client version 3.2-9 or newer
  mingw-virt-viewer-0.5.3-24 or newer
Comment 5 Uri Lublin 2013-07-24 09:12:14 EDT
Works for me with:
RHEVM-M 3.2.0-11.29.el6ev

Client: Win7 64
  usbclerk-win-0.1-11
  virt-viewer 0.5.6-1 (mingw)

Guest: RHEL pre 6.5
Comment 6 Uri Lublin 2013-07-24 09:14:35 EDT
Closing as duplicate of 842816
Please reopen if reproducible.

*** This bug has been marked as a duplicate of bug 842816 ***

Note You need to log in before you can comment on or make changes to this bug.