Bug 868360 - HA does not properly handle expired messages
HA does not properly handle expired messages
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
Development
Unspecified Unspecified
high Severity unspecified
: 2.3
: ---
Assigned To: Alan Conway
MRG Quality Engineering
: OtherQA
Depends On:
Blocks: 698367
  Show dependency treegraph
 
Reported: 2012-10-19 11:14 EDT by Jason Dillaman
Modified: 2013-03-19 12:41 EDT (History)
5 users (show)

See Also:
Fixed In Version: qpid-cpp-0.18-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache JIRA QPID-4379 None None None 2012-10-19 14:25:06 EDT

  None (edit)
Description Jason Dillaman 2012-10-19 11:14:20 EDT
Description of problem:
If a message expires in a queue before the HA replicator is able to browse the message, the message will be skipped and not replicated.  This results in the expired message's async completion never being finalized which can stall the original source of the expired message since it will never receive a completion.

Oct 18 10:56:02 itcm24 qpidd[48819]: 2012-10-18 10:56:02 [Broker] debug Browser skipping message from 'QueueXyz'

Version-Release number of selected component (if applicable):
Qpid 0.18

How reproducible:
Frequently

Steps to Reproduce:
1. It's a race condition between a message expiring in the queue and the HA browsing subscription being able to replicate it.
  
Actual results:
The expired message is skipped and its async completion is never finalized.

Expected results:
While it is not truly necessary for the HA replicating subscription to replicate an expired message, the async completion needs to be finished.

Additional info:

Note You need to log in before you can comment on or make changes to this bug.