This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 868364 - HA replicating subscriptions should not auto-delete queues
HA replicating subscriptions should not auto-delete queues
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
Development
Unspecified Unspecified
high Severity unspecified
: 2.3
: ---
Assigned To: Alan Conway
MRG Quality Engineering
: OtherQA
Depends On:
Blocks: 698367
  Show dependency treegraph
 
Reported: 2012-10-19 11:21 EDT by Jason Dillaman
Modified: 2013-03-19 12:38 EDT (History)
6 users (show)

See Also:
Fixed In Version: qpid-cpp-0.18-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-19 12:38:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache JIRA QPID-4391 None None None 2012-10-24 14:44:33 EDT

  None (edit)
Description Jason Dillaman 2012-10-19 11:21:14 EDT
Description of problem:
When an auto-delete queue is replicated, the replicating subscription attempts to auto-delete the queue after it has already been auto-deleted by the closing of the last non-HA consumer.  An issue occurs if a new auto-delete queue with the same name is created shortly after the deletion of the previously queue.  This can occur when a client subscribes to an auto-delete queue and is temporarily disconnected from the broker.  It is possible for the cancelled HA subscription to remove the newly created queue from the queue registry since the old and new queues use the same names.  The HA replicating subscription should not execute the auto-delete logic when the subscription is cancelled. 

Version-Release number of selected component (if applicable):
Qpid 0.18

How reproducible:
Frequently

Steps to Reproduce:
Race condition between a consumer auto-deleting and recreating a queue of the same name and the HA replicating subscription auto-deleting the original queue.  If the HA replicating subscription auto-deletes the original queue after the new queue is created, the new queue is removed from the queue registry.
  
Actual results:
New queue is removed from the queue registry.

Expected results:
HA subscription does not attempt to auto-delete the queue and therefore the new queue is not removed from the queue registry.

Additional info:
Comment 1 Alan Conway 2012-10-24 01:48:22 EDT
Fixed on branch aconway-ha-3 off 0.18- mrg, 2 commits:

0e6686e Bug:868364 - QPID:4391 HA ignore stale responses.
4cfebe5 Bug 868364 - QPID:4391: HA replicating subscriptions should not auto-delete queues

Note You need to log in before you can comment on or make changes to this bug.