Bug 868373 - F18 ppc64 beta TC4.1 anaconda hangs at installing bootloader with UnicodeDecodeError
F18 ppc64 beta TC4.1 anaconda hangs at installing bootloader with UnicodeDeco...
Status: CLOSED DUPLICATE of bug 854959
Product: Fedora
Classification: Fedora
Component: python-meh (Show other bugs)
18
powerpc Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-19 11:59 EDT by Robert Knight
Modified: 2012-10-22 12:39 EDT (History)
4 users (show)

See Also:
Fixed In Version: python-meh-0.17-1.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-22 12:38:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (6.92 KB, text/x-log)
2012-10-19 11:59 EDT, Robert Knight
no flags Details
ifcfg.log (641 bytes, text/x-log)
2012-10-19 12:00 EDT, Robert Knight
no flags Details
packaging.log (187.29 KB, text/x-log)
2012-10-19 12:01 EDT, Robert Knight
no flags Details
program.log (143.45 KB, text/x-log)
2012-10-19 12:02 EDT, Robert Knight
no flags Details
storage.log (190.60 KB, text/x-log)
2012-10-19 12:02 EDT, Robert Knight
no flags Details
syslog (83.03 KB, application/octet-stream)
2012-10-19 12:03 EDT, Robert Knight
no flags Details
vncserver.log (7.72 KB, text/x-log)
2012-10-19 12:03 EDT, Robert Knight
no flags Details

  None (edit)
Description Robert Knight 2012-10-19 11:59:03 EDT
Created attachment 630120 [details]
anaconda.log

Description of problem:
Installing ppc64 Beta TC4.1 on an Apple Mac G5, vnc based installation freezes at the "Installing bootloader" stage with the message:

UnicodeDecodeError: 'utf8' codec can't decode byte 0xbd in position 260213: invalid start byte

on the text console.


Version-Release number of selected component (if applicable):
18.16

How reproducible:
Always

Steps to Reproduce:
1. Start installation from DVD.
2. load i2c_powermac to prevent fans from running away in shell.
3. Remove all previous Linux partitions with "Reclaim"
4. Take defaults.
  
Actual results:
Installation proceeds normally up to the installation of the bootloader, then hangs.

Expected results:
Completion of the installation.

Additional info:
Comment 1 Robert Knight 2012-10-19 12:00:59 EDT
Created attachment 630122 [details]
ifcfg.log
Comment 2 Robert Knight 2012-10-19 12:01:41 EDT
Created attachment 630123 [details]
packaging.log
Comment 3 Robert Knight 2012-10-19 12:02:10 EDT
Created attachment 630124 [details]
program.log
Comment 4 Robert Knight 2012-10-19 12:02:49 EDT
Created attachment 630125 [details]
storage.log
Comment 5 Robert Knight 2012-10-19 12:03:12 EDT
Created attachment 630126 [details]
syslog
Comment 6 Robert Knight 2012-10-19 12:03:45 EDT
Created attachment 630127 [details]
vncserver.log
Comment 7 Robert Knight 2012-10-19 12:39:31 EDT
Might be caused by missing creation of encrypted_password attribute of MacYaboot object (Yaboot object?) which will cause bootloader.py to fail on access (around line 1669)
Comment 8 Chris Lumens 2012-10-21 22:16:27 EDT
Are you getting a traceback?  If so, can you please attach the complete /tmp/anaconda-tb-* file to this report?
Comment 9 Robert Knight 2012-10-22 08:45:18 EDT
Not getting a saved traceback.  The /tmp/anaconda-tb-* file is present but zero length.  There was a traceback on the main screen, however.  I'll attempt to reproduce it and copy it.
Comment 10 Robert Knight 2012-10-22 09:28:05 EDT
From the "main" panel:

CONTINUE CLICKED
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/exception.py", line 61, in run_handleException_on_idleobj)
  File "/usr/lib64/python2.7/site-packages/meh/handler.py", line 101, in handleException
    fd.write(self.exnText.encode("utf-8"))
UnicodeDecodeError: 'utf8' codec can't decode byte 0xbd in position 255207: invalid start byte

The offset is different this time.
Comment 11 Chris Lumens 2012-10-22 10:30:08 EDT
Sigh, looks like a traceback in python-meh trying to display the real traceback.  Reassigning for the moment, but it'll come back to us when this issue is fixed.
Comment 12 Vratislav Podzimek 2012-10-22 12:38:33 EDT
(In reply to comment #10)
> From the "main" panel:
> 
> CONTINUE CLICKED
> Traceback (most recent call last):
>   File "/usr/lib64/python2.7/site-packages/pyanaconda/exception.py", line
> 61, in run_handleException_on_idleobj)
>   File "/usr/lib64/python2.7/site-packages/meh/handler.py", line 101, in
> handleException
>     fd.write(self.exnText.encode("utf-8"))
> UnicodeDecodeError: 'utf8' codec can't decode byte 0xbd in position 255207:
> invalid start byte
This is something that has been resolved in bug #854959.

*** This bug has been marked as a duplicate of bug 854959 ***
Comment 13 Vratislav Podzimek 2012-10-22 12:39:40 EDT
Please use some compose with the new python-meh and file a bug with the original traceback (will get displayed) then.

Note You need to log in before you can comment on or make changes to this bug.