Bug 868376 - Dependency on groff defeats split of groff into groff and groff-base
Dependency on groff defeats split of groff into groff and groff-base
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: less (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Bříza
Fedora Extras Quality Assurance
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-19 12:16 EDT by Matthew Miller
Modified: 2012-12-20 10:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 10:00:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Miller 2012-10-19 12:16:04 EDT
Description of problem:

The groff-base package contains only necessary parts of groff formatting
system which are required to display manual pages, and the groff's default
display device (PostScript).

But, less requires groff itself. Since man-db requires less, the net result is that 


I tested this with a minimal install, and removing the "groff" package (as long as "groff-base" is installed, of course) has no impact on either man or less's ability to display man pages.




Version-Release number of selected component (if applicable):

less-444-5.fc17.src.rpm
Comment 1 Matthew Miller 2012-10-19 12:27:18 EDT
(Uh, "the net result is that installing man pulls in both groff and groff-base.")
Comment 2 Martin Bříza 2012-10-25 11:47:36 EDT
You're right, groff has about 4MB in size so the difference will be noticeable.
Comment 3 Fedora Update System 2012-10-25 11:51:38 EDT
less-444-6.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/less-444-6.fc17
Comment 4 Fedora Update System 2012-10-25 11:55:57 EDT
less-444-9.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/less-444-9.fc18
Comment 5 Fedora Update System 2012-10-26 15:33:36 EDT
Package less-444-9.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing less-444-9.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16892/less-444-9.fc18
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-12-20 10:00:52 EST
less-444-6.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.