Bug 868395 - Windows Client: Spice Option: Pass Ctrl-Alt-Del to virtual machine is grayed out
Windows Client: Spice Option: Pass Ctrl-Alt-Del to virtual machine is grayed out
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-userportal (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.2.0
Assigned To: Frantisek Kobzik
Jiri Belka
virt
:
Depends On:
Blocks: 915537
  Show dependency treegraph
 
Reported: 2012-10-19 13:41 EDT by Vimal Patel
Modified: 2013-06-11 05:21 EDT (History)
8 users (show)

See Also:
Fixed In Version: sf1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot of Win 7 client showing Ctrl_Alt_Del option checked (156.41 KB, image/png)
2012-10-22 10:13 EDT, Vimal Patel
no flags Details

  None (edit)
Description Vimal Patel 2012-10-19 13:41:16 EDT
Description of problem:
For the Power User Portal or User Portal console spice options, for a Windows client, the option to Pass Ctrl-Alt-Del to virtual machine is checked and grayed out.  For a RHEL client, the option is available.  Is there a reason for this?  If there is a reason for not giving the user this option, why even show the option grayed out, it would be better to not have it at all since it isn't an option. 

*Tested on Windows 7 client and RHEL

Version-Release number of selected component (if applicable):
RHEVM 3.1 si20

How reproducible:
100%

Steps to Reproduce:
1. Go to the RHEVM user portal (Basic or Extended)
2. Go to console options
3.
  
Actual results:
Pass Ctrl-Alt-Del to virtual machine is checked and grayed out.

Expected results:
Pass Ctrl-Alt-Del to virtual machine is an option that can be modified

Additional info:
Comment 1 Michal Skrivanek 2012-10-22 07:42:02 EDT
can you please just confirm on windows os the checkbox is in fact checked? It should not be. Grayed out is correct. It's intended to give you a hint when you mouse over that this is not supported on Windows platform.
Comment 2 Vimal Patel 2012-10-22 10:12:09 EDT
Yes, on both Windows clients that I tested, I see it checked and grayed out.  The hover message does say: Not supported for this client OS, which I did not notice before.  I will attach a screenshot.
Comment 3 Vimal Patel 2012-10-22 10:13:41 EDT
Created attachment 631570 [details]
Screenshot of Win 7 client showing Ctrl_Alt_Del option checked
Comment 4 Michal Skrivanek 2012-10-22 10:22:31 EDT
thanks.
So I'd propose to address just the checkbox, it should be unchecked and grayed out.
Doesn't seem urgent to me and I'd prefer to not to risk breaking anything, so I propose a fix for 3.2
Comment 5 Frantisek Kobzik 2012-10-29 11:05:58 EDT
In gerrit: http://gerrit.ovirt.org/#/c/8906/
Comment 6 Frantisek Kobzik 2012-11-01 11:28:43 EDT
Merged upstream: 42d5e3004eca7ce4cebd8d3b19e4e2dc43d28c8b
Comment 7 Jiri Belka 2013-01-28 09:28:07 EST
OK, sf4.
Comment 8 Michal Skrivanek 2013-04-02 12:26:38 EDT
hm, I wonder why it should be unchecked....as per bug 928862 it should be actually send as enabled.
Comment 9 Tomas Jelinek 2013-04-03 03:26:15 EDT
it has to be unchecked because otherwise if you press ctrl+alt+del both the client and guest receives them (we had an issue with it recently: https://bugzilla.redhat.com/show_bug.cgi?id=918650)
Comment 10 Itamar Heim 2013-06-11 04:44:36 EDT
3.2 has been released
Comment 11 Itamar Heim 2013-06-11 04:44:36 EDT
3.2 has been released
Comment 12 Itamar Heim 2013-06-11 04:44:54 EDT
3.2 has been released
Comment 13 Itamar Heim 2013-06-11 04:50:58 EDT
3.2 has been released
Comment 14 Itamar Heim 2013-06-11 05:21:59 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.