Bug 868416 - what is the accelerator for this menu item? _Help > _Getting Started Ctrl+H
what is the accelerator for this menu item? _Help > _Getting Started Ctrl+H
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: candlepin-bugs
IDM QE LIST
:
Depends On:
Blocks: 771481 771748
  Show dependency treegraph
 
Reported: 2012-10-19 14:53 EDT by John Sefler
Modified: 2012-11-27 15:29 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-27 15:29:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Why do these accelerators disagree? (46.70 KB, image/png)
2012-10-19 14:53 EDT, John Sefler
no flags Details
A closer look at accelerators in another language (39.27 KB, image/png)
2012-10-19 16:00 EDT, John Sefler
no flags Details

  None (edit)
Description John Sefler 2012-10-19 14:53:05 EDT
Created attachment 630228 [details]
Why do these accelerators disagree?

Description of problem:
Look at the attached screenshot.  The "Getting Started" menu item has an underscored G accelerator, yet the helper to the right shows "Ctrl+H".  The "Ctrl+H" is what actually works.  Shouldn't these agree?

Version-Release number of selected component (if applicable):
[root@jsefler-rhel59 ~]# rpm -q subscription-manager-gui
subscription-manager-gui-1.0.23-1.el5
Comment 1 RHEL Product and Program Management 2012-10-19 14:58:12 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Matt Reid 2012-10-19 15:04:53 EDT
Nice catch! I would vote for G, since we have Alt + H to show the Help menu and it probably would be better to not double up on the same letter.
Comment 3 John Sefler 2012-10-19 16:00:56 EDT
Created attachment 630234 [details]
A closer look at accelerators in another language

Educate me on how this should work, because I thought I knew, but I don't...
Here is what I have observed:

Clicking Alt+ the underscored accelerator character of the top level menu (_System _Help) works in all languages even when the underscored character changes by the translators.  This seems good.

The Ctrl+X help text to the right of each pop-up menu item appears constant; it does not change with LANG. This seems wrong. Shouldn't it be a function of the underscored character within its menu item to its left?

Because the menu items are translated and the translators change which character is accelerated with an underscore, they do not match the Ctrl+X help text to their right.  This confuses me.

Clicking Ctrl+ the underscored character in the menu items does nothing.  It only has an effect if what you click matches one of the Ctrl+X values on the right of the menu items.

Do I not know how to use accelerators?  Or is this GUI broken?
Comment 4 Matt Reid 2012-10-19 16:30:11 EDT
Poking at this briefly in a 5.9 vm, it looks like the CTRL + X are what you can use without the menu open, and they don't necessarily have to match the underscored character. The underscored character (if it isn't associated with a corresponding CTRL shortcut) only functions when the menu is currently open (and you just hit the underscored character, no modifiers).

So in our case, I can hit ALT + S, which opens up the System Menu, and then hit 'i', and it'll open up the Import Cert Dialog. Since our CTRL accelerators and the underscored characters match up (in English), I can also press CTRL + I, without the System Menu open, and have the Import cert dialog open up.

Looking at some GNOME apps, the underscored character and the CTRL shortcut don't always match (look at Paste in Gedit, P is underscored, but the CTRL shortcut is CTRL + V). Since our menus aren't very complicated, it would be nice if everything stayed consistent across translations and matched the underscored character they picked, but I'm not sure if we can vary the CTRL bindings per locale. That might be a question for Jbowes or Dgoodwin. I agree its a bit confusing to have them vary, and it would make more sense for the CTRL accelerators to be something somewhat logical in their language.
Comment 5 RHEL Product and Program Management 2012-10-30 02:15:04 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 6 Bryan Kearney 2012-11-27 15:29:12 EST
The accelerators can be translated. So, closing this.

Note You need to log in before you can comment on or make changes to this bug.