Bug 868417 - Wrong setting in systemd unit, or wrong config
Wrong setting in systemd unit, or wrong config
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mcollective (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Steve Traylen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-19 15:00 EDT by Michael Scherer
Modified: 2013-09-02 14:07 EDT (History)
1 user (show)

See Also:
Fixed In Version: mcollective-2.2.3-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-18 17:33:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Scherer 2012-10-19 15:00:10 EDT
Mcollective do not start after installation.

Either daemonize should be set to 1 in /etc/mcollective/server.cfg and client.cfg, or the type should be set to Type=simple. 

However, it seems to have already a issue, since this was modified on 
f94ae5c431247e6d5ebb14fb4c708c9949d90e3f. Either the upstream default was changed ( likely ), and then we should fix the configuration ( like making sure daemonize is set to 1 ). This could be done with perl or augeas.
Comment 1 Steve Traylen 2013-04-17 04:08:53 EDT
I can't remember why now but I have in the .spec file

%if 0%{?rhel}
%{__sed} -i -e 's/^daemonize = .*$/daemonize = 1/' etc/server.cfg.dist
%endif
%if 0%{?fedora} >= 18
%{__sed} -i -e 's/^daemonize = .*$/daemonize = 0/' etc/server.cfg.dist
%endif

i.e daemonize for SysV but not for systemd. This is the default in the supplied configuration so we stick with that.
Comment 2 Fedora Update System 2013-04-17 07:01:30 EDT
mcollective-2.2.3-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/mcollective-2.2.3-1.el6
Comment 3 Fedora Update System 2013-04-17 07:01:58 EDT
mcollective-2.2.3-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mcollective-2.2.3-1.fc19
Comment 4 Fedora Update System 2013-04-17 12:24:44 EDT
Package mcollective-2.2.3-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mcollective-2.2.3-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-5875/mcollective-2.2.3-1.fc19
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-08-18 17:33:38 EDT
mcollective-2.2.3-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2013-09-02 14:07:19 EDT
mcollective-2.2.3-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.