Bug 868435 - error message for invalid rhc app create --timeout should be more specific.
error message for invalid rhc app create --timeout should be more specific.
Status: CLOSED WONTFIX
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Hiro Asari
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-19 16:43 EDT by Peter Ruan
Modified: 2015-05-14 22:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-16 12:08:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Ruan 2012-10-19 16:43:51 EDT
Description of problem:
error message for invalid rhc app create --timeout should be more specific.  In the previous version, if the user typed in the incorrect timeout value, the error message reads 'Timeout must be specified as a number greater than 0'.  Currently, the error message is very geneic. invalid argument: --timeout test


Version-Release number of selected component (if applicable):
rhc 0.99.9


How reproducible:

always

Steps to Reproduce:
1. rhc app create testapp php-5.3 --timeout test
2.
3.
  
Actual results:
invalid argument: --timeout test


Expected results:
should give an error message that's more appropriate like 'time out value must be integer greater than 0'

Additional info:
Comment 1 Hiro Asari 2012-11-16 12:08:00 EST
Right now, the output includes this bit.

===
Global Options
  -l, --rhlogin login       OpenShift login
  -p, --password password   OpenShift password
  -d, --debug               Turn on debugging
  --noprompt                Suppress the interactive setup wizard from running before a command
  --config FILE             Path of a different config file
  -h, --help                Display help documentation
  -v, --version             Display version information
  --timeout seconds         Set the timeout in seconds for network commands
===

Going beyond this will probably be too problematic, since the message "invalid argument: --timeout test" is ultimately coming from Ruby's standard library, and there is no easy way to customize the message. We might be able to *guess* what arguments might have been passed, but I suspect it will lead to some unmaintainable error checking.

I'm marking this as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.