Bug 868485 - ZLIB_ERROR raised with AWS
ZLIB_ERROR raised with AWS
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: zlib-ada (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Björn Persson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 810676
  Show dependency treegraph
 
Reported: 2012-10-20 05:03 EDT by Pavel Zhukov
Modified: 2012-10-25 03:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-25 03:17:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
remove external zlib-ada from aws (1.19 KB, text/plain)
2012-10-20 05:05 EDT, Pavel Zhukov
no flags Details
sample program (165 bytes, application/octet-stream)
2012-10-20 14:45 EDT, Pavel Zhukov
no flags Details
patch for zlib (revert?) (1003 bytes, patch)
2012-10-20 23:49 EDT, Pavel Zhukov
no flags Details | Diff
Correct patch (583 bytes, patch)
2012-10-20 23:53 EDT, Pavel Zhukov
no flags Details | Diff
project file to build the test program (64 bytes, text/plain)
2012-10-21 15:15 EDT, Björn Persson
no flags Details

  None (edit)
Description Pavel Zhukov 2012-10-20 05:03:30 EDT
Description of problem:
zlib-error raised if AWS uses external zlib-ada instead bundled

Version-Release number of selected component (if applicable):
zlib-ada-1.4-0.3.20120830CVS.fc17.x86_64

How reproducible:
always

Steps to Reproduce:
1.build aws: https://github.com/landgraf/aws-fedora
2.build sample code:  http://vpaste.net/72ZYu
3.run sample program
  
Actual results:
raised ZLIB.ZLIB_ERROR


Expected results:
exit code 0

Additional info:
There is no error with aws compiled from https://github.com/landgraf/aws-fedora/tree/zlib
Comment 1 Pavel Zhukov 2012-10-20 05:05:01 EDT
Created attachment 630381 [details]
remove external zlib-ada from aws
Comment 2 Björn Persson 2012-10-20 08:03:26 EDT
(In reply to comment #0)
> 2.build sample code:  http://vpaste.net/72ZYu

That's not a sample program. It's a diff between two versions of AWS.Client. Did you link to the wrong file?
Comment 3 Pavel Zhukov 2012-10-20 14:45:19 EDT
Created attachment 630575 [details]
sample program
Comment 4 Pavel Zhukov 2012-10-20 14:46:04 EDT
You can check any program with AWS.Client.Get function and https://
Comment 5 Pavel Zhukov 2012-10-20 23:49:38 EDT
Created attachment 630726 [details]
patch for zlib (revert?)

This patch works for me.
Comment 6 Pavel Zhukov 2012-10-20 23:53:12 EDT
Created attachment 630741 [details]
Correct patch
Comment 7 Björn Persson 2012-10-21 15:15:51 EDT
Created attachment 630978 [details]
project file to build the test program

I can't reproduce this. I'm using zlib-1.2.5-7.fc17.x86_64, zlib-ada-1.4-0.3.20120830CVS.fc17.x86_64 and aws-2.11.0-8.fc17.x86_64. I'm attaching the project file I build your test program with. I've tried building the test program with both GPRbuild and Gnatmake, and I get exit code 0 every time I run it.

Can you provide more details? A stack trace of where the exception is raised maybe?
Comment 8 Pavel Zhukov 2012-10-25 03:17:07 EDT
It's magic. I've rebuilt and reinstalled aws and zlib-ada and cannot reproduce this bug.
I'll test with clean installation later.

Note You need to log in before you can comment on or make changes to this bug.