Bug 868496 - nemo and nautilus fight each other for desktop icon display
nemo and nautilus fight each other for desktop icon display
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: nemo (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: leigh scott
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-20 06:15 EDT by Michael Scherer
Modified: 2012-12-20 10:43 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 10:43:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Scherer 2012-10-20 06:15:47 EDT
/etc/xdg/autostart/nemo-autostart.desktop and /etc/xdg/autostart/nautilus-autostart.desktop both specify to start nemo and nautilus for the same condition :
AutostartCondition=GSettings org.gnome.desktop.background show-desktop-icons


If both are installed and the option is specified, this mean that both will be started, however, starting nautilus will disable nemo and vice versa. This make nemo interfering with nautilus out of the box and vice versa, and that can be quite surprising for users. I am not sure that starting nautilus -n and nemo -n at the same time will always end in the same way. The only solution is to disable one of them from gnome-session-properties.

( as a side note, using the same title for both is quite surprising, and I do not see why nemo reused the name File )

So maybe nemo should stop using the gnome name space for his setting, so this would not interfer with gnome.
Comment 1 leigh scott 2012-10-20 06:23:30 EDT
This is a upstream issue
Comment 2 Michael Scherer 2012-10-20 09:27:46 EDT
Then report it upstream. And the duty of integration with the distribution is not upstream.
Comment 3 leigh scott 2012-10-20 10:18:15 EDT
(In reply to comment #2)
> Then report it upstream. And the duty of integration with the distribution
> is not upstream.

I see Clem has fixed it :-)

https://github.com/linuxmint/nemo/commit/eda34ff3cfdc416ccb4360b8d0166da70b5e5123
Comment 4 Michael Scherer 2012-10-20 10:42:46 EDT
Wel, the fix is wrong, because it would still interfer with gnome-shell. Ie someone installing cinnamon would just see icon appearing on the desktop on his gnome-shell session.

And not, as long as the bug is in Fedora, closing it as "not a bug" is not a solution.
Comment 5 Fedora Update System 2012-10-21 09:42:40 EDT
nemo-1.0.5-2.fc18, cinnamon-1.6.3-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/nemo-1.0.5-2.fc18,cinnamon-1.6.3-1.fc18
Comment 6 Fedora Update System 2012-10-21 15:23:39 EDT
Package nemo-1.0.5-2.fc18, cinnamon-1.6.3-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing nemo-1.0.5-2.fc18 cinnamon-1.6.3-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16572/nemo-1.0.5-2.fc18,cinnamon-1.6.3-1.fc18
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-12-20 10:43:30 EST
nemo-1.0.5-2.fc18, cinnamon-1.6.3-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.