Bug 868502 - Build with XFS support, and -qt with $RPM_LD_FLAGS
Build with XFS support, and -qt with $RPM_LD_FLAGS
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: transmission (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rahul Sundaram
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-20 06:32 EDT by Ville Skyttä
Modified: 2013-02-01 12:02 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-01 11:43:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Build with XFS support, and -qt with $RPM_LD_FLAGS (1.45 KB, patch)
2012-10-20 06:32 EDT, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2012-10-20 06:32:51 EDT
Created attachment 630411 [details]
Build with XFS support, and -qt with $RPM_LD_FLAGS

transmission has some apparently non-intrusive XFS support which isn't built, and -qt is not built with $RPM_LD_FLAGS. Fix attached.
Comment 1 Kalev Lember 2012-10-24 14:16:44 EDT
Hi Ville,

Thanks for the patch.

I've been doing some drive-by transmission maintenance lately. Not sure if anyone is currently paying attention to transmission bugs; I discovered this one accidentally.

I don't think the QMAKE_LFLAGS hack is something we should do in this spec file, but it should instead be the default for qmake-qt4. Have you talked to the qt maintainers about this?

Regarding the XFS support, I have no idea what it does so I don't feel confident applying this. Maybe someone else who knows what it does can chime in.
Comment 2 Ville Skyttä 2012-10-24 16:24:08 EDT
Regarding LDFLAGS, that'll be partially handled by #868554. Not sure why you see usage of QMAKE_LFLAGS as a hack - that is the way how one passes LDFLAGS to qmake builds. But after #868554 it is no longer that "urgent".

About XFS, see libtransmission/fdlimit.c. If that's seen undesirable, building without XFS should be done explicitly so that builds are reproducible. I suppose the only way to do that is by BuildConflicts: xfsprogs-devel or patching as there's no --without/disable-xfs build flag.
Comment 3 Kalev Lember 2012-10-24 19:25:02 EDT
Oh this is very nice, the fix in ticket #868554 is exactly what I had in mind when I said it should be the default for qmake-qt4.

Another thing we could do to make it nicer is to create a %{qmake_qt4} macro which would wrap the standard flags, like

%qmake_qt4 \
  QMAKE_LFLAGS="$LDFLAGS" \\\
  qmake-qt4

or similar.


(In reply to comment #2)
> About XFS, see libtransmission/fdlimit.c. If that's seen undesirable,
> building without XFS should be done explicitly so that builds are
> reproducible. I suppose the only way to do that is by BuildConflicts:
> xfsprogs-devel or patching as there's no --without/disable-xfs build flag.

Ah, yes, I see now.

Looks like it's file preallocation fallback code, but on a modern linux distro we already have fallocate64() and posix_fallocate() available in glibc so the XFS-specific code doesn't really add any value, as much as I can tell.
Comment 4 Ville Skyttä 2012-10-25 15:20:31 EDT
(In reply to comment #3)

> Another thing we could do to make it nicer is to create a %{qmake_qt4} macro
> which would wrap the standard flags

Yeah, why not, filed as #870199.
Comment 5 Fedora Update System 2013-01-19 21:25:39 EST
transmission-2.76-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/transmission-2.76-1.fc18
Comment 6 Fedora Update System 2013-01-19 21:27:06 EST
transmission-2.76-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/transmission-2.76-1.fc17
Comment 7 Fedora Update System 2013-01-22 20:35:56 EST
Package transmission-2.76-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing transmission-2.76-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-1207/transmission-2.76-1.fc17
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-02-01 11:43:44 EST
transmission-2.76-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2013-02-01 12:02:56 EST
transmission-2.76-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.