Bug 868563 - sometimes created partitions are not accepted by the main hub (custom partitioning selected is shown, but the exclamation mark remains)
sometimes created partitions are not accepted by the main hub (custom partiti...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-20 16:43 EDT by Reartes Guillermo
Modified: 2014-02-05 07:39 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-05 07:39:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of the result (90.90 KB, image/png)
2012-10-20 16:43 EDT, Reartes Guillermo
no flags Details
storage log (314.31 KB, text/plain)
2012-10-21 22:57 EDT, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2012-10-20 16:43:51 EDT
Created attachment 630643 [details]
screenshot of the result

Description of problem:

I am unable to start the installation process after manually creating partitions that appears to be accepted by anaconda itself.

Disks:
1 x 9.5gb (UN-PARTITIONED)
4 x 400mb (PARTITIONED: GPT, no partitions)
There are more 400mb disks, but they are not selected or used.

Intended setup:

On disk 1 (the big one):
/boot  (ext4) 512mb
SWAP   SWAP   512mb
/      (ext4)   8gb

On the other 4 small disks:
/home (BTRFS RAID 10, if i understood the UI correctly) 350mb

See performed steps below.

Version-Release number of selected component (if applicable):
F18b TC6

How reproducible:
always

Steps to Reproduce:

0. Enter INSTALLATION DESTINATION, Storage, and select the first
five disks. (1x9.5gb, 4x400mb).

1. Continue, Press 'let me customize [...]', Continue, enter MANUAL
PARTITIONING. In this case, it will show no pre-existing partitions.

2. Add '+' a /boot of 512mb
3. Add '+' a swap of 512mb
4. Add '+' a / of 8.4gb
5. Add '+' a /home of 350mb

6. Click (select) /home, and '+' in 'customize', switch 'device type' to BTRFS

7. Check both 'redundancy (mirror)' and 'Optimized performance (stripe)'

8. Press 'finish partitioning'. 

9. The main hub appears as the screen-shot shows. It is not possible to install Fedora for some reason.

  
Actual results:
cannot install

Expected results:
either being able to install (if the partitions created make sense) or an error if the partitions should have been rejected for some reason.

Additional info:
Comment 1 Chris Lumens 2012-10-21 22:28:34 EDT
Please attach /tmp/storage.log to this bug report.
Comment 2 Reartes Guillermo 2012-10-21 22:57:25 EDT
Created attachment 631216 [details]
storage log
Comment 3 Chris Lumens 2013-01-07 14:26:58 EST
I just tried to reproduce this, but was unsuccessful in doing so.  Can you please try again and give us an update?  Thanks.
Comment 4 Reartes Guillermo 2013-01-07 14:53:03 EST
I tried again, but i got bug 891385 (ZeroDivisionError: float division by zero) as soon as i checked both mirror and stripe and hit 'apply'. 

Note: i selected scheme 'standard partition' since no LVM was involved and this bug-report is very old, i don't even remember if the default was LVM or PLAIN at that time.
Comment 5 Fedora End Of Life 2013-12-21 04:09:35 EST
This message is a reminder that Fedora 18 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 18. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '18'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 18's end of life.

Thank you for reporting this issue and we are sorry that we may not be 
able to fix it before Fedora 18 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior to Fedora 18's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 6 Fedora End Of Life 2014-02-05 07:39:06 EST
Fedora 18 changed to end-of-life (EOL) status on 2014-01-14. Fedora 18 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.