Bug 8686 - Lost soundcard-setup
Lost soundcard-setup
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: initscripts (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-20 20:58 EST by Enrico Scholz
Modified: 2014-03-16 22:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-21 12:57:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2000-01-20 20:58:17 EST
To restore the soundcard-setup (volume) the initscripts are looking for an
installed sound-module. The loading of this depends on an entry in
/etc/conf.modules which is being checked for in /etc/rc.d/rc.sysinit with:

  if grep -s -q "^alias sound " /etc/conf.modules ; then

But if the /etc/conf.modules file was edited manually, tabulators are often
used. Such entries (e.g. "alias sound\t...") will not be detected by your
pattern.

A better check would be for the regexp '^alias\>[^w]*\<sound\>'
Comment 1 Bill Nottingham 2000-01-21 12:32:59 EST
Fixed in initscripts-4.84-1.
Comment 2 Enrico Scholz 2000-01-21 12:54:59 EST
Sorry, but in my last posting I have not noticed that aliases for names like
"sound-slot-0" are possible. Because I am not sure if all possible entries can
be detected by regexp's I suggest to check the normalized output of "modprobe
-c":

if modprobe -c | grep -s -q '^alias sound '; ...
if modprobe -c | grep -s -q '^alias midi '; ...
Comment 3 Bill Nottingham 2000-01-21 12:57:59 EST
What it does is 'egrep "^alias[[:space:]]+sound[[:space:]]+" conf.modules | awk
'{ print $3 }', and if that alias is not 'off', it loads whatever that is.

That should be good enough for now. If we can get rid of the
ISA dma issues, we'll drop loading the modules entirely
and let kmod do its thing.

Note You need to log in before you can comment on or make changes to this bug.