This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 868603 - [abrt] systemd-44-20.fc17: log_assert: Process /usr/lib/systemd/systemd-readahead-collect was killed by signal 6 (SIGABRT)
[abrt] systemd-44-20.fc17: log_assert: Process /usr/lib/systemd/systemd-reada...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michal Schmidt
Fedora Extras Quality Assurance
abrt_hash:5242b58895bd6b7967a8e3737c2...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-21 00:00 EDT by cxt
Modified: 2012-12-20 10:12 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 10:12:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: core_backtrace (962 bytes, text/plain)
2012-10-21 00:00 EDT, cxt
no flags Details
File: environ (179 bytes, text/plain)
2012-10-21 00:00 EDT, cxt
no flags Details
File: backtrace (6.48 KB, text/plain)
2012-10-21 00:00 EDT, cxt
no flags Details
File: limits (1.29 KB, text/plain)
2012-10-21 00:00 EDT, cxt
no flags Details
File: cgroup (196 bytes, text/plain)
2012-10-21 00:00 EDT, cxt
no flags Details
File: maps (2.24 KB, text/plain)
2012-10-21 00:00 EDT, cxt
no flags Details
File: dso_list (638 bytes, text/plain)
2012-10-21 00:00 EDT, cxt
no flags Details
File: open_fds (275 bytes, text/plain)
2012-10-21 00:00 EDT, cxt
no flags Details
File: var_log_messages (290 bytes, text/plain)
2012-10-21 00:00 EDT, cxt
no flags Details

  None (edit)
Description cxt 2012-10-21 00:00:05 EDT
Version-Release number of selected component:
systemd-44-20.fc17

Additional info:
libreport version: 2.0.14
abrt_version:   2.0.13
backtrace_rating: 4
cmdline:        /usr/lib/systemd/systemd-readahead-collect
crash_function: log_assert
kernel:         3.6.2-4.fc17.i686.PAE

truncated backtrace:
:Thread no. 1 (5 frames)
: #3 log_assert at src/shared/log.c:634
: #4 log_assert_failed at src/shared/log.c:639
: #5 close_nointr at src/shared/util.c:257
: #7 close_nointr_nofail at src/shared/util.c:277
: #8 collect at src/readahead/readahead-collect.c:465
Comment 1 cxt 2012-10-21 00:00:09 EDT
Created attachment 630763 [details]
File: core_backtrace
Comment 2 cxt 2012-10-21 00:00:11 EDT
Created attachment 630764 [details]
File: environ
Comment 3 cxt 2012-10-21 00:00:14 EDT
Created attachment 630765 [details]
File: backtrace
Comment 4 cxt 2012-10-21 00:00:17 EDT
Created attachment 630766 [details]
File: limits
Comment 5 cxt 2012-10-21 00:00:20 EDT
Created attachment 630767 [details]
File: cgroup
Comment 6 cxt 2012-10-21 00:00:22 EDT
Created attachment 630768 [details]
File: maps
Comment 7 cxt 2012-10-21 00:00:29 EDT
Created attachment 630769 [details]
File: dso_list
Comment 8 cxt 2012-10-21 00:00:31 EDT
Created attachment 630770 [details]
File: open_fds
Comment 9 cxt 2012-10-21 00:00:34 EDT
Created attachment 630771 [details]
File: var_log_messages
Comment 10 Michal Schmidt 2012-10-22 08:28:04 EDT
This is caused by an incorrect check for fd validity:

  next_iteration:
          if (m->fd)
                  close_nointr_nofail(m->fd);
Comment 12 Fedora Update System 2012-10-22 21:04:58 EDT
systemd-195-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/systemd-195-1.fc18
Comment 13 Fedora Update System 2012-10-23 02:48:43 EDT
Package systemd-195-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing systemd-195-1.fc18'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16709/systemd-195-1.fc18
then log in and leave karma (feedback).
Comment 14 Fedora Update System 2012-10-26 11:43:10 EDT
systemd-44-21.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/systemd-44-21.fc17
Comment 15 Fedora Update System 2012-10-26 15:37:54 EDT
Package systemd-195-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing systemd-195-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16709/systemd-195-2.fc18
then log in and leave karma (feedback).
Comment 16 Fedora Update System 2012-12-20 10:12:54 EST
systemd-44-21.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.