Bug 868611 - [abrt] chrpath-0.13-8.fc17: strncmp: Process /usr/bin/chrpath was killed by signal 11 (SIGSEGV)
[abrt] chrpath-0.13-8.fc17: strncmp: Process /usr/bin/chrpath was killed by s...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: chrpath (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
abrt_hash:2e2fc5053eff26e5d6ad4d6f1e0...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-21 02:59 EDT by Maciek Borzecki
Modified: 2013-04-04 12:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-04 12:09:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (791 bytes, text/plain)
2012-10-21 02:59 EDT, Maciek Borzecki
no flags Details
File: environ (3.24 KB, text/plain)
2012-10-21 02:59 EDT, Maciek Borzecki
no flags Details
File: backtrace (72.71 KB, text/plain)
2012-10-21 02:59 EDT, Maciek Borzecki
no flags Details
File: limits (1.29 KB, text/plain)
2012-10-21 02:59 EDT, Maciek Borzecki
no flags Details
File: cgroup (129 bytes, text/plain)
2012-10-21 02:59 EDT, Maciek Borzecki
no flags Details
File: maps (1.34 KB, text/plain)
2012-10-21 02:59 EDT, Maciek Borzecki
no flags Details
File: dso_list (226 bytes, text/plain)
2012-10-21 02:59 EDT, Maciek Borzecki
no flags Details
File: var_log_messages (391 bytes, text/plain)
2012-10-21 02:59 EDT, Maciek Borzecki
no flags Details
File: open_fds (105 bytes, text/plain)
2012-10-21 02:59 EDT, Maciek Borzecki
no flags Details
Fix for this issue (393 bytes, patch)
2012-10-22 06:25 EDT, Petr Machata
no flags Details | Diff

  None (edit)
Description Maciek Borzecki 2012-10-21 02:59:15 EDT
Description of problem:
Called 'chrpath --hep'  (that's a typo --hep instead of --help).

Version-Release number of selected component:
chrpath-0.13-8.fc17

Additional info:
libreport version: 2.0.14
abrt_version:   2.0.13
backtrace_rating: 4
cmdline:        chrpath --hep
crash_function: strncmp
kernel:         3.6.1-1.fc17.x86_64

truncated backtrace:
:Thread no. 1 (4 frames)
: #0 strncmp at ../sysdeps/x86_64/strcmp.S:2112
: #1 _getopt_internal_r at getopt.c:548
: #2 _getopt_internal at getopt.c:1177
: #3 getopt_long at getopt1.c:66
Comment 1 Maciek Borzecki 2012-10-21 02:59:18 EDT
Created attachment 630789 [details]
File: core_backtrace
Comment 2 Maciek Borzecki 2012-10-21 02:59:20 EDT
Created attachment 630790 [details]
File: environ
Comment 3 Maciek Borzecki 2012-10-21 02:59:23 EDT
Created attachment 630791 [details]
File: backtrace
Comment 4 Maciek Borzecki 2012-10-21 02:59:25 EDT
Created attachment 630792 [details]
File: limits
Comment 5 Maciek Borzecki 2012-10-21 02:59:27 EDT
Created attachment 630793 [details]
File: cgroup
Comment 6 Maciek Borzecki 2012-10-21 02:59:29 EDT
Created attachment 630794 [details]
File: maps
Comment 7 Maciek Borzecki 2012-10-21 02:59:31 EDT
Created attachment 630795 [details]
File: dso_list
Comment 8 Maciek Borzecki 2012-10-21 02:59:33 EDT
Created attachment 630796 [details]
File: var_log_messages
Comment 9 Maciek Borzecki 2012-10-21 02:59:35 EDT
Created attachment 630797 [details]
File: open_fds
Comment 10 Petr Machata 2012-10-22 06:25:30 EDT
Created attachment 631386 [details]
Fix for this issue

This fixes the issue, but I can't currently push this update due to missing privileges.

Note You need to log in before you can comment on or make changes to this bug.