Bug 868640 - squid-3.2.3 is available
squid-3.2.3 is available
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: squid (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomáš Hozza
Fedora Extras Quality Assurance
: FutureFeature, Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-21 07:04 EDT by Upstream Release Monitoring
Modified: 2012-12-01 03:43 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-20 08:35:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Upstream Release Monitoring 2012-10-21 07:04:09 EDT
Latest upstream release: 3.2.3
Current version in Fedora Rawhide: 3.2.2
URL: ftp://ftp.squid-cache.org/pub/squid/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 1 Tomáš Hozza 2012-10-22 04:13:12 EDT
Fixed in squid-3.2.3-1.fc18.
Comment 2 Bojan Smojver 2012-10-26 01:51:16 EDT
Any chance of getting a build for F-17?
Comment 3 Michal Luscon 2012-10-26 11:32:23 EDT
I am sorry, but rebase in f17 is against fedora updates policy. If you need version 3.2.3, you can find it in koji( https://koji.fedoraproject.org/koji/ ).
Comment 4 Bojan Smojver 2012-10-26 17:36:45 EDT
What rebase? 3.2.0.16 was a release candidate of this same major version. If anything, you shoud be required to update.
Comment 5 Bojan Smojver 2012-10-26 18:43:46 EDT
http://www.squid-cache.org/Versions/v3/3.2/
Comment 6 Henrik Nordström 2012-10-27 07:02:50 EDT
Correct.

Squid-3.2.3 is a bugfix release in the Squid-3.2 series and should be pushed to F17 and F16.
Comment 7 Michal Luscon 2012-10-28 13:18:00 EDT
I am sorry for mystification. F16 and F17 will be updated soon.
Comment 8 Fedora Update System 2012-10-29 04:07:49 EDT
squid-3.2.3-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-16962/squid-3.2.3-2.fc18
Comment 9 Michal Luscon 2012-11-15 10:03:51 EST
Squid-3.2.3 requires higher version of openssl than is present in F17. I would like to update Squid but it is not possible because of mentioned issue. I am sorry for any inconvenience.
Comment 10 Bojan Smojver 2012-11-15 18:03:01 EST
(In reply to comment #9)
> Squid-3.2.3 requires higher version of openssl than is present in F17. I
> would like to update Squid but it is not possible because of mentioned
> issue. I am sorry for any inconvenience.

That is not true. I just built squid with --enable-ssl on F-17:
---------------------
$ lsb_release -rd
Description:	Fedora release 17 (Beefy Miracle)
Release:	17

$ src/squid -v
Squid Cache: Version 3.2.3
configure options:  '--enable-ssl' --enable-ltdl-convenience

$ ldd src/squid
	linux-vdso.so.1 =>  (0x00007fff077f2000)
	libpthread.so.0 => /lib64/libpthread.so.0 (0x0000003ae8a00000)
	libcrypt.so.1 => /lib64/libcrypt.so.1 (0x0000003130800000)
	libssl.so.10 => /lib64/libssl.so.10 (0x0000003fc6a00000)
	libcrypto.so.10 => /lib64/libcrypto.so.10 (0x0000003af8e00000)
	libgssapi_krb5.so.2 => /lib64/libgssapi_krb5.so.2 (0x0000003fc6200000)
	libkrb5.so.3 => /lib64/libkrb5.so.3 (0x0000003fc6600000)
	libk5crypto.so.3 => /lib64/libk5crypto.so.3 (0x0000003af7200000)
	libcom_err.so.2 => /lib64/libcom_err.so.2 (0x0000003fc5e00000)
	libnsl.so.1 => /lib64/libnsl.so.1 (0x0000003afd600000)
	libresolv.so.2 => /lib64/libresolv.so.2 (0x0000003aea200000)
	librt.so.1 => /lib64/librt.so.1 (0x0000003ae9200000)
	libdl.so.2 => /lib64/libdl.so.2 (0x0000003ae8e00000)
	libstdc++.so.6 => /lib64/libstdc++.so.6 (0x0000003aefa00000)
	libm.so.6 => /lib64/libm.so.6 (0x0000003ae9600000)
	libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x0000003aeba00000)
	libc.so.6 => /lib64/libc.so.6 (0x0000003ae8600000)
	/lib64/ld-linux-x86-64.so.2 (0x0000003ae8200000)
	libfreebl3.so => /lib64/libfreebl3.so (0x0000003130400000)
	libz.so.1 => /lib64/libz.so.1 (0x0000003ae9a00000)
	libkrb5support.so.0 => /lib64/libkrb5support.so.0 (0x0000003af6e00000)
	libkeyutils.so.1 => /lib64/libkeyutils.so.1 (0x0000003af6600000)
	libselinux.so.1 => /lib64/libselinux.so.1 (0x0000003ae9e00000)

$ rpm -qf /lib64/libssl.so.10
openssl-1.0.0j-2.fc17.x86_64
---------------------
Comment 11 Bojan Smojver 2012-11-15 18:37:16 EST
Also built RPMS from the f17 branch of the Fedora squid git on my F-17 machine. This is what I had to change in the spec to do it:
---------------------------
diff --git a/squid.spec b/squid.spec
index 7a6cd62..3b4ce3e 100644
--- a/squid.spec
+++ b/squid.spec
@@ -3,7 +3,7 @@
 ## % define __find_requires %{SOURCE99}
 
 Name:     squid
-Version:  3.2.0.16
+Version:  3.2.3
 Release:  1%{?dist}
 Summary:  The Squid proxy caching server
 Epoch:    7
@@ -114,6 +114,7 @@ The squid-sysvinit contains SysV initscritps support.
 LDFLAGS="-pie"
 
 %configure \
+   --disable-strict-error-checking \
    --exec_prefix=/usr \
    --libexecdir=%{_libdir}/squid \
    --localstatedir=/var \
---------------------------

If --disable-strict-error-checking is not added to configure, it will fail in tools.cc, because a couple functions' return values are not checked.

So, looks doable.

PS. Master branch will indeed fail to build, not because of --enable-ssl, but because of --enable-crtd. There are patches floating around to fix that too. See this for instance: http://squid-web-proxy-cache.1019090.n4.nabble.com/attachment/4656119/0/certificate_db_cc_compile_fix_patch.txt
Comment 12 Fedora Update System 2012-11-20 08:19:10 EST
squid-3.2.3-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/squid-3.2.3-2.fc17
Comment 13 Michal Luscon 2012-11-20 08:35:34 EST
Openssl build issue was caused by configure option --enable-ssl-crtd. Since this option wasn't enabled in F17, I have successfully prepared update preserving F16 configure options and you can find it now in testing.
Comment 14 Fedora Update System 2012-11-20 10:29:24 EST
squid-3.2.3-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/squid-3.2.3-2.fc16
Comment 15 Fedora Update System 2012-12-01 03:32:13 EST
squid-3.2.3-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2012-12-01 03:43:28 EST
squid-3.2.3-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.