This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 868645 - New update to 0ad-data is corrupted
New update to 0ad-data is corrupted
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: 0ad-data (Show other bugs)
17
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: MERCIER Jonathan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-21 07:19 EDT by David Utidjian
Modified: 2012-10-28 03:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-23 15:26:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Utidjian 2012-10-21 07:19:00 EDT
Description of problem:
When using the command:
'sudo yum update 0ad-data'
or
'sudo yum install 0ad-data'

the yum utility complains that the update or install fails due to problems with a file in the package.

Version-Release number of selected component (if applicable):
0ad-data-0.12747-16.20121011svn12747.fc17.noarch.rpm

which is part of

0ad-0.12747-16.20121011svn12747.fc17.i686.rpm


How reproducible:

Always.


Steps to Reproduce:
1. Try to install or update 0ad.
2. 
3.
  
Actual results:

[utidjian@pie ~]$ sudo yum install 0ad-data
Loaded plugins: langpacks, presto, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package 0ad-data.noarch 0:0.12747-16.20121011svn12747.fc17 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package     Arch      Version                              Repository     Size
================================================================================
Installing:
 0ad-data    noarch    0.12747-16.20121011svn12747.fc17     fedora-0ad    308 M

Transaction Summary
================================================================================
Install  1 Package

Total download size: 308 M
Installed size: 1.3 G
Is this ok [y/N]: y
Downloading Packages:
0ad-data-0.12747-16.20121011svn12747.fc17.noarch.rpm     | 308 MB     01:15     
Running Transaction Check
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : 0ad-data-0.12747-16.20121011svn12747.fc17.noarch             1/1 
Error unpacking rpm package 0ad-data-0.12747-16.20121011svn12747.fc17.noarch
error: unpacking of archive failed on file /usr/share/0ad/mods/public/art/textures/terrain/types/desert_pebbles_rough_wet.png;5083c072: cpio: read
  Verifying  : 0ad-data-0.12747-16.20121011svn12747.fc17.noarch             1/1 

Failed:
  0ad-data.noarch 0:0.12747-16.20121011svn12747.fc17                            

Complete!

Expected results:

To install correctly.

Additional info:

None.
Comment 1 Paulo Andrade 2012-10-21 11:56:50 EDT
This bug report should be for the packages at
http://repos.fedorapeople.org/repos/bioinfornatics/0ad

I just offered bioinfornatics comaintainership of 0ad
and 0ad-data packages.
Comment 2 MERCIER Jonathan 2012-10-21 12:05:27 EDT
thanks to the report david a i go to check what is the problem. 
to start could you tell to me why you install 0ad-data without 0ad ?
Comment 3 David Utidjian 2012-10-21 15:05:01 EDT
(In reply to comment #2)
> thanks to the report david a i go to check what is the problem. 
> to start could you tell to me why you install 0ad-data without 0ad ?

Heh... good question. I DO have the 0ad installed fine. It was the 0ad-data package that failed.

Incidentally, I followed the link from pcpa's post (above) to the package and I found the full 0ad-data package, downloaded it, installed it and the program now works fine.

Please note:
http://repos.fedorapeople.org/repos/bioinfornatics/0ad/fedora-17/i386/
Shows the 0ad-data rpm as 308MB BUT

http://repos.fedorapeople.org/repos/bioinfornatics/0ad/fedora-17/noarch/
Shows the 0ad-data rpm as 750MB.

So, apparently, the repo folders are not in sync. There is an incomplete copy of 0ad-data in i386 folder which is what yum tries to download.

The problem is solved for me but it will fail for anyone else using 'yum update 0ad, or 'yum install 0ad' until the folders are brought in to sync.

Thanks to pcpa and you for helping me solve this problem.

If you have any other questions please let me know.
Comment 4 MERCIER Jonathan 2012-10-23 15:26:50 EDT
it should be fixed now

below link that is to install 0ad repo
http://repos.fedorapeople.org/repos/bioinfornatics/0ad/fedora-17/noarch/0ad-repo-17-2.fc17.noarch.rpm

but 0ad is now into fedora, what is the diferrence:
 -into fedora 0ad is the "stable" release
- into 0ad repo follow frequently upstream

0ad repo is usefull to test new feature or if they are a bug into a stable release

If problem persist reopen this bug you are welcome

Note: you should to do:
- remove 0ad
- do a yum clean all
- yum install --nogppgcheck http://repos.fedorapeople.org/repos/bioinfornatics/0ad/fedora-17/noarch/0ad-repo-17-2.fc17.noarch.rpm
- yum install 0ad
Comment 5 MERCIER Jonathan 2012-10-28 03:18:18 EDT
since today (28/10/12) this bug is fixed

Note You need to log in before you can comment on or make changes to this bug.