Bug 868647 - RHEVM-CLI: Sending CTRL + C signal while password prompt appears causes to rhevm-cli to fall with traceback
RHEVM-CLI: Sending CTRL + C signal while password prompt appears causes to rh...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-cli (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.2.0
Assigned To: Michael Pasternak
Ilia Meerovich
infra
: ZStream
Depends On:
Blocks: 880696
  Show dependency treegraph
 
Reported: 2012-10-21 08:51 EDT by Ilia Meerovich
Modified: 2016-07-04 20:07 EDT (History)
13 users (show)

See Also:
Fixed In Version: SF4
Doc Type: Bug Fix
Doc Text:
If Ctrl+C was pressed at a password prompt, for example when logging into rehvm-shell, it caused rhevm-cli to crash with Traceback. This has been fixed so that if Ctrl+C is pressed at a password prompt, the operator is returned to their original Bash prompt.
Story Points: ---
Clone Of:
: 880696 (view as bug list)
Environment:
Last Closed: 2013-06-10 16:28:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ilia Meerovich 2012-10-21 08:51:35 EDT
Description of problem:
Sending CTRL + C signal while password prompt appears causes to rhevm-cli to fall with traceback

Version-Release number of selected component (if applicable):
rhevm-cli-3.1.0.17-1.el6ev.noarch


How reproducible:
Deterministic

Steps to Reproduce:
1.try to connect: for example: "rhevm-shell  -c -l moo -u boo"
2.when password: prompt appears press CTRL+C

  
Actual results:
[imeerovi@imeerovi ART]$ rhevm-shell  -c -l moo -u boo
Password: Traceback (most recent call last):
  File "/usr/bin/rhevm-shell", line 9, in <module>
    load_entry_point('rhevm-shell==3.1.0.17-SNAPSHOT', 'console_scripts', 'rhevm-shell')()
  File "/usr/lib/python2.6/site-packages/ovirtcli/main.py", line 27, in main
    context = OvirtCliExecutionContext(sys.argv, parser)
  File "/usr/lib/python2.6/site-packages/ovirtcli/context.py", line 45, in __init__
    super(OvirtCliExecutionContext, self).__init__(args=args, option_parser=option_parser)
  File "/usr/lib/python2.6/site-packages/cli/context.py", line 70, in __init__
    self._load_settings()
  File "/usr/lib/python2.6/site-packages/cli/context.py", line 126, in _load_settings
    self.__collect_connection_data()
  File "/usr/lib/python2.6/site-packages/cli/context.py", line 95, in __collect_connection_data
    self.settings['ovirt-shell:password'] = getpass.getpass()
  File "/usr/lib64/python2.6/getpass.py", line 71, in unix_getpass
    passwd = _raw_input(prompt, stream, input=input)
  File "/usr/lib64/python2.6/getpass.py", line 133, in _raw_input
    line = input.readline()
KeyboardInterrupt


Expected results:
controlled cli exit or some other controlled behaviou (by design)

Additional info:
Comment 1 Yaniv Kaul 2012-10-23 08:57:36 EDT
*** Bug 869269 has been marked as a duplicate of this bug. ***
Comment 2 David Jaša 2012-10-23 09:05:54 EDT
The ctrl-c should be trapped and handled in all situations, as described in the duplicate.
Comment 3 Michael Pasternak 2012-11-15 05:38:22 EST
(In reply to comment #2)
> The ctrl-c should be trapped and handled in all situations, as described in
> the duplicate.

it is handled, just getpass library of my control.
Comment 4 Michael Pasternak 2012-11-15 05:38:46 EST
i've failed reproducing KeyboardInterrupt in ctrl+c, but added handling
to this use-case anyway.

4af73c9f47bacb0d6bbf37c169dc238eab6cc816
Comment 5 Michael Pasternak 2012-11-15 05:46:30 EST
(In reply to comment #2)
> The ctrl-c should be trapped and handled in all situations, as described in
> the duplicate.

btw, this is not dup., but CLOSED-NOT_A_BUG
Comment 6 Ilia Meerovich 2012-11-25 07:04:41 EST
Which build will contain this bugfix?
Comment 7 Michael Pasternak 2012-11-25 07:11:52 EST
(In reply to comment #6)
> Which build will contain this bugfix?

the 3.1.1 release
Comment 10 Ilia Meerovich 2013-02-05 04:26:17 EST
[imeerovi@imeerovi ART]$ /usr/bin/rhevm-shell -c --url=https://leonid_rhevm.qa.lab.tlv.redhat.com:443/api/ -u admin@internal -I
Password: 
[imeerovi@imeerovi ART]$ 

verified with rhevm-cli-3.2.0.3-1.el6ev.noarch
Comment 12 errata-xmlrpc 2013-06-10 16:28:23 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0890.html

Note You need to log in before you can comment on or make changes to this bug.