Bug 868702 - AttributeError: 'MountpointSelector' object has no attribute '_root'
AttributeError: 'MountpointSelector' object has no attribute '_root'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
abrt_hash:7d1ce6340a19e9a7ef6c32a1400...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-21 16:48 EDT by Reartes Guillermo
Modified: 2012-11-23 00:22 EST (History)
5 users (show)

See Also:
Fixed In Version: anaconda-18.20-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-23 00:22:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (212.30 KB, text/plain)
2012-10-21 16:48 EDT, Reartes Guillermo
no flags Details
File: product (6 bytes, text/plain)
2012-10-21 16:48 EDT, Reartes Guillermo
no flags Details
File: type (9 bytes, text/plain)
2012-10-21 16:48 EDT, Reartes Guillermo
no flags Details
File: ifcfg.log (1.10 KB, text/plain)
2012-10-21 16:48 EDT, Reartes Guillermo
no flags Details
File: storage.log (70.00 KB, text/plain)
2012-10-21 16:48 EDT, Reartes Guillermo
no flags Details
File: version (11 bytes, text/plain)
2012-10-21 16:48 EDT, Reartes Guillermo
no flags Details
File: environ (780 bytes, text/plain)
2012-10-21 16:48 EDT, Reartes Guillermo
no flags Details
File: anaconda.log (10.05 KB, text/plain)
2012-10-21 16:48 EDT, Reartes Guillermo
no flags Details
File: syslog (67.89 KB, text/plain)
2012-10-21 16:48 EDT, Reartes Guillermo
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-21 16:48 EDT, Reartes Guillermo
no flags Details
File: packaging.log (2.38 KB, text/plain)
2012-10-21 16:48 EDT, Reartes Guillermo
no flags Details
File: cmdline_file (96 bytes, text/plain)
2012-10-21 16:48 EDT, Reartes Guillermo
no flags Details
File: release (24 bytes, text/plain)
2012-10-21 16:48 EDT, Reartes Guillermo
no flags Details
File: program.log (31.76 KB, text/plain)
2012-10-21 16:48 EDT, Reartes Guillermo
no flags Details
Anaconda log without, then with updates image from comment #16 (72.43 KB, application/octet-stream)
2012-10-22 19:30 EDT, Xavier Hourcade
no flags Details

  None (edit)
Description Reartes Guillermo 2012-10-21 16:48:07 EDT
Description of problem:
enter manual partitioning
select swap (in other), click encrypt, apply
select swap (now in new...), deselect encrypt, apply


Version-Release number of selected component:
anaconda-18.19

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.1-1.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.19 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1725, in on_remove_clicked
:    if selector._root:
:AttributeError: 'MountpointSelector' object has no attribute '_root'
Comment 1 Reartes Guillermo 2012-10-21 16:48:14 EDT
Created attachment 631064 [details]
File: anaconda-tb
Comment 2 Reartes Guillermo 2012-10-21 16:48:17 EDT
Created attachment 631065 [details]
File: product
Comment 3 Reartes Guillermo 2012-10-21 16:48:19 EDT
Created attachment 631067 [details]
File: type
Comment 4 Reartes Guillermo 2012-10-21 16:48:21 EDT
Created attachment 631069 [details]
File: ifcfg.log
Comment 5 Reartes Guillermo 2012-10-21 16:48:24 EDT
Created attachment 631070 [details]
File: storage.log
Comment 6 Reartes Guillermo 2012-10-21 16:48:26 EDT
Created attachment 631071 [details]
File: version
Comment 7 Reartes Guillermo 2012-10-21 16:48:29 EDT
Created attachment 631072 [details]
File: environ
Comment 8 Reartes Guillermo 2012-10-21 16:48:31 EDT
Created attachment 631073 [details]
File: anaconda.log
Comment 9 Reartes Guillermo 2012-10-21 16:48:34 EDT
Created attachment 631074 [details]
File: syslog
Comment 10 Reartes Guillermo 2012-10-21 16:48:37 EDT
Created attachment 631075 [details]
File: hashmarkername
Comment 11 Reartes Guillermo 2012-10-21 16:48:39 EDT
Created attachment 631076 [details]
File: packaging.log
Comment 12 Reartes Guillermo 2012-10-21 16:48:41 EDT
Created attachment 631077 [details]
File: cmdline_file
Comment 13 Reartes Guillermo 2012-10-21 16:48:43 EDT
Created attachment 631078 [details]
File: release
Comment 14 Reartes Guillermo 2012-10-21 16:48:46 EDT
Created attachment 631079 [details]
File: program.log
Comment 15 Xavier Hourcade 2012-10-22 10:36:51 EDT
Anaconda custom partitioning, removing one of two volume swaps, from the F18 list.

Existing partition layout includes volumes for two distro installations (and more) :
. sda1 ext2 (neutral loader)
- sda3 lvm {boot1, boot2, ...}
- sda5 lvm+luks {root1, root2, swap1, swap2, ..., data}

Anaconda permits to unlock the crypt fine, then assign the desired mount points to F18 installation : one of the boot volumes, one of the root volumes. As per the swaps, both were automatically added to F18 partition layout proposal.

1. Select one of the swaps
2. Hit the "-" button at the list bottom

This leads to this crash.


Package: anaconda-18.19-1.fc18.x86_64
OS Release: Fedora release 18
Comment 16 Chris Lumens 2012-10-22 11:06:27 EDT
Does updates=http://clumens.fedorapeople.org/868702.img fix this for you?
Comment 17 Reartes Guillermo 2012-10-22 12:56:12 EDT
I reproduced several times with these steps:

0. Booting a guest with preexisting partitions.
1. Enter STORAGE: INSTALLATION DESTINATION, select the first disk.
2. Press continue and select MANUAL PARTITIONING.
3. Expand the 'UNKNOWN' tree. Select a partition (RAID in this example)
4. Expand 'Customize' Tree, check 'encrypt' & press 'apply'

This causes the selected partition entry to be relocated in the 'New Fedora' tree. Please note that the 'Software RAID' and other stuff is still shown. These should not be shown, since there is nothing selected at the moment.

5. Expand the 'New Fedora...' Tree. 

Software RAID will be selected. That is abnormal, because only items in an expanded Tree can be selected. Most likely when it was relocated the 'UNKNOWN' tree should have been collapsed and the 'New Fedora' tree should have been expanded, keeping the item selected.

7. By just removing '-' the partition, then the error pop-pups.

Clearly, i could not reproduce it with previous comment methods.

I tested the updates image from previous comment and with these steps i could no longer reproduce the issue. I tried a couple of times, just to be sure.

Additional Info:
When i perform steps 3 & 4, i failed to notice that when i expand the 'New Fedora...' Tree there is a BIOS Boot entry which i did not put there, it just appears.

And when booting with the updates image, when removing the partition, it also removes that 'ghost' BIOS Boot entry too.

Existing Partitions on the selected disk: GPT

1  Bios Boot           (EF02)   1mb
2  STANDARD PARTITION  (0700) 4.9gb
3  STANDARD PARTITION  (0700) 500mb
4  RAID PARTITION      (FD00)   2gb
5  STANDARD PARTITION  (0700) 1.9gb
Comment 18 Chris Lumens 2012-10-22 13:43:23 EDT
Okay, I'll post the patch later.  Got some other stuff to sort out first.
Comment 19 Xavier Hourcade 2012-10-22 19:30:16 EDT
Created attachment 631773 [details]
Anaconda log without, then with updates image from comment #16

Thanks, I tested your image too :

- Crash is no longer reproduceable with the updates

However

- Second swap is still not removeable from F18 layout
- Is the previously selected / volume, removed instead ?

That's a very unexpected behaviour: I had assigned / and /boot, hit Apply Changes, went to F18 section and tried to remove of of the swaps. Root was surely still showing up in the GUI. That's only when I hit "Finish Partioning" that, surprisingly, Anaconda main screen did show the section unsatisfied. As we an see in anaconda.log, it states no / part was selected... Indeed, while entering custom partitioning again, / partition was no longer listed in F18 section. I assigned it again and, this time, it took it into consideration.

100% reproduceable (and reproduced at least 3 times).
Hopes the log helps.
Comment 20 Chris Lumens 2012-10-23 13:26:25 EDT
Please open a separate bug for the separate issue.  Thanks.
Comment 21 Adam Williamson 2012-11-23 00:22:53 EST
This bug looks to have been fixed for many anaconda builds now but missed being closed. If you find you are still experiencing it with Fedora 18 Beta (RC1) or later, please re-open the bug.

(ref comment #19)

Note You need to log in before you can comment on or make changes to this bug.