Bug 868704 - F18b TC6 anaconda: network shows 'connected' but it should be 'connecting..' (incorrect network status in the main hub)
F18b TC6 anaconda: network shows 'connected' but it should be 'connecting..' ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-21 16:58 EDT by Reartes Guillermo
Modified: 2012-11-23 00:24 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-23 00:24:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reartes Guillermo 2012-10-21 16:58:16 EDT
Description of problem:

Anaconda is still connecting, but in the main hub it says: "connected" which is not true. And might be false in case the connection fails, like what happened to me.

Version-Release number of selected component (if applicable):
F18b TC6

How reproducible:
depends

Steps to Reproduce:
boot a guest/host in which dhcp for some (yet unknown) reason
does not acquire an ip in the end.
the main hub shows connected, but it is connecting and in the end it fails to connect, so it is important to display 'connecting' instead of 'connected' which is not true.
  
Actual results:
incorrect status report in them main hub, one might decide to go to installation source and select closest mirror, but there might be no network.

Expected results:
report an accurate status of the network.

Additional info:
this guest does not get an ip for some reason, maybe there are mo more free leases, i will check later. As a workaround i set the ip manually (with some caveats i will try to report later) and it connects ok.
Comment 1 Radek Vykydal 2012-10-30 11:33:23 EDT
This is fixed in bug 871129 where we more accurately discriminate "Connected" and "Not Connected" (the latter including connecting and disconnecting states). I'll keep this BZ open to add "Connecting...", "Disconnecting..." states eventually.
Comment 2 Fedora Update System 2012-11-09 19:56:02 EST
anaconda-18.28-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-17823/anaconda-18.28-1.fc18
Comment 3 Fedora Update System 2012-11-09 19:56:08 EST
anaconda-18.28-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-17823/anaconda-18.28-1.fc18
Comment 4 Fedora Update System 2012-11-10 14:38:32 EST
Package anaconda-18.28-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.28-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17823/anaconda-18.28-1.fc18
then log in and leave karma (feedback).
Comment 5 Adam Williamson 2012-11-23 00:24:27 EST
This bug looks to have been fixed since 18.28 but missed being closed. If you find you are still experiencing it with Fedora 18 Beta (RC1) or later, please re-open the bug.

Note You need to log in before you can comment on or make changes to this bug.