Bug 868706 - [abrt] libreoffice-core-3.5.7.2-2.fc17: __memcpy_ssse3_back: Process /usr/lib64/libreoffice/program/soffice.bin was killed by signal 11 (SIGSEGV)
[abrt] libreoffice-core-3.5.7.2-2.fc17: __memcpy_ssse3_back: Process /usr/lib...
Status: CLOSED DUPLICATE of bug 831628
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:096bce3e44260daaf6a624cf16f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-21 17:19 EDT by Hugo Melendez
Modified: 2012-10-22 03:46 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-22 03:46:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: core_backtrace (664 bytes, text/plain)
2012-10-21 17:19 EDT, Hugo Melendez
no flags Details
File: environ (1.66 KB, text/plain)
2012-10-21 17:19 EDT, Hugo Melendez
no flags Details
File: limits (1.29 KB, text/plain)
2012-10-21 17:19 EDT, Hugo Melendez
no flags Details
File: backtrace (146.77 KB, text/plain)
2012-10-21 17:19 EDT, Hugo Melendez
no flags Details
File: cgroup (131 bytes, text/plain)
2012-10-21 17:19 EDT, Hugo Melendez
no flags Details
File: maps (93.92 KB, text/plain)
2012-10-21 17:19 EDT, Hugo Melendez
no flags Details
File: dso_list (20.30 KB, text/plain)
2012-10-21 17:19 EDT, Hugo Melendez
no flags Details
File: open_fds (222 bytes, text/plain)
2012-10-21 17:19 EDT, Hugo Melendez
no flags Details
File: var_log_messages (342 bytes, text/plain)
2012-10-21 17:19 EDT, Hugo Melendez
no flags Details

  None (edit)
Description Hugo Melendez 2012-10-21 17:19:15 EDT
Version-Release number of selected component:
libreoffice-core-3.5.7.2-2.fc17

Additional info:
libreport version: 2.0.14
abrt_version:   2.0.13
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --calc file:///home/hmelende/Desktop/Proyectos/Garrahan%20NAT%2020120815/01.%20Planificaci%C3%B3n/00.%20Facturaci%C3%B3n/P&L%20Garrahan%20NAT.ods --splash-pipe=6
crash_function: __memcpy_ssse3_back
kernel:         3.6.1-1.fc17.x86_64

truncated backtrace:
:Thread no. 1 (3 frames)
: #0 __memcpy_ssse3_back at ../sysdeps/x86_64/multiarch/memcpy-ssse3-back.S:1706
: #1 ICEConnectionWorker at /usr/src/debug/libreoffice-3.5.7.2/vcl/unx/generic/app/sm.cxx:662
: #2 osl_thread_start_Impl at thread.c:277
Comment 1 Hugo Melendez 2012-10-21 17:19:18 EDT
Created attachment 631090 [details]
File: core_backtrace
Comment 2 Hugo Melendez 2012-10-21 17:19:20 EDT
Created attachment 631091 [details]
File: environ
Comment 3 Hugo Melendez 2012-10-21 17:19:23 EDT
Created attachment 631092 [details]
File: limits
Comment 4 Hugo Melendez 2012-10-21 17:19:27 EDT
Created attachment 631093 [details]
File: backtrace
Comment 5 Hugo Melendez 2012-10-21 17:19:30 EDT
Created attachment 631094 [details]
File: cgroup
Comment 6 Hugo Melendez 2012-10-21 17:19:33 EDT
Created attachment 631095 [details]
File: maps
Comment 7 Hugo Melendez 2012-10-21 17:19:36 EDT
Created attachment 631096 [details]
File: dso_list
Comment 8 Hugo Melendez 2012-10-21 17:19:39 EDT
Created attachment 631097 [details]
File: open_fds
Comment 9 Hugo Melendez 2012-10-21 17:19:41 EDT
Created attachment 631098 [details]
File: var_log_messages
Comment 10 David Tardon 2012-10-22 03:14:52 EDT
The ICE connection thread is copying to memory allocated by rtl_allocateMemory while rtl_memory_fini is in progress in the main thread. That cannot end well... I wonder if the restructured code in current master handles that...
Comment 11 Stephan Bergmann 2012-10-22 03:46:54 EDT

*** This bug has been marked as a duplicate of bug 831628 ***

Note You need to log in before you can comment on or make changes to this bug.