Bug 868711 - Include "gluster volume geo-replication status" in the gluster sos plugin
Include "gluster volume geo-replication status" in the gluster sos plugin
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sos (Show other bugs)
6.3
All Linux
low Severity low
: rc
: 6.5
Assigned To: Bryn M. Reeves
Filip Holec
:
Depends On:
Blocks: 1036752
  Show dependency treegraph
 
Reported: 2012-10-21 18:16 EDT by Brad Hubbard
Modified: 2016-04-18 06:21 EDT (History)
7 users (show)

See Also:
Fixed In Version: sos-2.2-43.el6
Doc Type: Enhancement
Doc Text:
Feature: The gluster plug-in now collects the output of the "gluster volume geo-replication-status" command by default. Reason: This diagnostic output may be important for debugging problems related to Gluster geographic replication. Result (if any):
Story Points: ---
Clone Of:
: 1036752 (view as bug list)
Environment:
Last Closed: 2013-11-21 17:35:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brad Hubbard 2012-10-21 18:16:52 EDT
Description of problem:

The sos gluster plugin should capture the output of the "gluster volume geo-replication status" command.
Comment 1 Bryn M. Reeves 2012-10-22 05:46:20 EDT
Can you file or clone this against the RHS component? Gluster folks want to retain control of the gluster module so this needs to be reviewed by them first (we just removed all the volume status stuff at their request).
Comment 2 Brad Hubbard 2012-10-22 16:52:29 EDT
Hey Bryn,

Already done, 868712.
Comment 3 Bryn M. Reeves 2013-06-03 08:54:24 EDT
Setting devel_ack based on RHS acceptance of this change in bug 868712.
Comment 4 Bryn M. Reeves 2013-08-12 15:03:35 EDT
Patches do not apply cleanly to the rhel-6 branch; looks like other changes have been made in the downstream (RHS) package.

I need to look into this before I can include this in 6.5.

If there are further differences then it may be preferable for us to just re-sync the gluster.py with the version in RHS - I don't want these two to diverge over time.
Comment 10 errata-xmlrpc 2013-11-21 17:35:26 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1688.html

Note You need to log in before you can comment on or make changes to this bug.