Bug 868742 - [anaconda-18.19] selecting environment other than GNOME and then selecting Gnome again gives Minimal install!
[anaconda-18.19] selecting environment other than GNOME and then selecting Gn...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F18-accepted/F18FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2012-10-21 22:27 EDT by Jens Petersen
Modified: 2012-11-23 00:31 EST (History)
5 users (show)

See Also:
Fixed In Version: anaconda-18.22-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-23 00:31:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2012-10-21 22:27:43 EDT
Description of problem:
With latest anaconda (F18 Beta TC6) if I change the install
environment from Gnome to a different one, then back to Gnome,
and then proceed to install I get a Minimal install not a
Gnome installation!

Version-Release number of selected component (if applicable):
anaconda-18.19-1.fc18

How reproducible:
100%

Steps to Reproduce:
1. Boot Fedora-18-Beta-TC6-x86_64-netinst.iso (anaconda-18.19)
2. Select other install environment and then select Gnome again
3. install
  
Actual results:
Minimal package set gets installed.

Expected results:
GNOME environment to be installed.
Comment 1 Jens Petersen 2012-10-21 22:42:39 EDT
Well I am not sure if this qualifies as a Blocker bug, but
the behaviour is certainly unexpected and one can imagine people
browsing the different optional groups in other package environments
before turning back to the Gnome default and ending up with a minimal install.
Comment 2 Andre Robatino 2012-10-21 22:48:27 EDT
I'd like to try reproducing this on both i386 and x86_64 and on both DVD and netinst. Do you mean you select another DE, press Done, then go back and select Gnome and press Done again? Or do you mean select another DE and then immediately select Gnome again, and then press Done?
Comment 3 Andre Robatino 2012-10-21 23:00:38 EDT
Never mind, I can reproduce it by selecting another DE and then immediately selecting Gnome again before pressing Done.
Comment 4 Andre Robatino 2012-10-21 23:08:41 EDT
It does NOT happen if you select another DE and press Done, then go back and select Gnome and press Done. I was able to reproduce the problem (selecting another DE and the immediately selecting Gnome before pressing Done) on the 32-bit DVD, So it probably affects both DVD and netinst on both arches.
Comment 5 Jens Petersen 2012-10-22 00:55:49 EDT
Right - I have been testing on x86_64 fwiw.

For now I am moving it to F18-accepted - but if people think it
is a blocker then please propose for F18Blocker.
Comment 6 Chris Lumens 2012-10-22 15:58:17 EDT
Okay, comment #3 makes this pretty easy to start debugging.  Thanks for the reproducer.
Comment 7 Fedora Update System 2012-10-31 22:52:50 EDT
anaconda-18.22-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.22-1.fc18
Comment 8 Fedora Update System 2012-11-01 14:28:53 EDT
Package anaconda-18.22-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.22-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17432/anaconda-18.22-1.fc18
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2012-11-02 00:07:06 EDT
anaconda-18.23-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.23-1.fc18
Comment 10 Fedora Update System 2012-11-02 21:06:46 EDT
anaconda-18.24-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.24-1.fc18
Comment 11 Jens Petersen 2012-11-04 21:49:35 EST
This looks fixed to me, thanks.

But now Basic X Window install enables the common optional groups
from Gnome by default: @gnome-desktop, @input-methods, and @firefox,
which it should not do.
Comment 12 Jens Petersen 2012-11-05 00:56:41 EST
> But now Basic X Window install enables the common optional groups
> from Gnome by default: @gnome-desktop, @input-methods, and @firefox,
> which it should not do.

I filed bug 873092 for this.  It seems to be just a UI problem
(ie the groups do not actually get installed).
Comment 13 Fedora Update System 2012-11-05 20:41:49 EST
anaconda-18.25-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.25-1.fc18
Comment 14 Fedora Update System 2012-11-06 21:13:57 EST
anaconda-18.26-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.26-1.fc18
Comment 15 Adam Williamson 2012-11-23 00:31:36 EST
This bug looks to have been fixed for many anaconda builds now but missed being closed. If you find you are still experiencing it with Fedora 18 Beta (RC1) or later, please re-open the bug.

(ref comment #11)

Note You need to log in before you can comment on or make changes to this bug.