Bug 868776 - [RHEV-H 6.4]Check "Available Space" and "Required Space" didn't work well on Disk Space Check Page during installing process.
[RHEV-H 6.4]Check "Available Space" and "Required Space" didn't work well on ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.4
Unspecified Unspecified
high Severity medium
: rc
: ---
Assigned To: Mike Burns
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-22 02:27 EDT by haiyang,dong
Modified: 2013-02-28 11:42 EST (History)
14 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-14.el6
Doc Type: Bug Fix
Doc Text:
Previously, due to a miscalculation when using the disk space check page, available space and required space were incorrect. This resulted in the Red Hat Enterprise Virtualization Hypervisor failing to install due to not having enough disk space. This has been fixed so that disk space is calculated correctly.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:42:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot for Disk Space Check Page (81.75 KB, image/jpeg)
2012-10-22 02:28 EDT, haiyang,dong
no flags Details

  None (edit)
Description haiyang,dong 2012-10-22 02:27:05 EDT
Description of problem: 
Clean install RHEV-H, Select USB device(/dev/sdb 3827MB) to use for booting RHEV-H,Select USB device(/dev/sdb) and USB device(/dev/sdc 3827MB) to use for installation of RHEV-H.
then,set Swap=4096MB Config=2048MB Logging=2048MB Data=2048MB on setting partition sizes page, it will prompt that "Available Space:3827MB" and "Required Space:10752MB" on Disk Space Check Page(Seen diskspacecheckpage.png),
but actually the available space should be 7654MB(/dev/sdb+/dev/sdc), and the required space should be 10802MB(UEFI/Bios+ROOT+RootBackup+Swap+Config+Logging+Data).

Version-Release number of selected component (if applicable): 
rhev-hypervisor6-6.4-20121015.1.el6

How reproducible: 
100% 

Steps to Reproduce: 
1. Boot from CD media and install RHEV-H.
2. Select USB device(/dev/sdb 3827MB) to use for booting RHEV-H.
3. Select  USB device(/dev/sdb) and USB device(/dev/sdc 3827MB) to use for installation of RHEV-H.
4. Set Swap=4096MB Config=2048MB Logging=2048MB Data=2048MB on setting partition sizes page,
and click the "Continue" button

Actual results: 
it will prompt Disk Space Check Page,but the label of "Available Space" and "Required Space" didn't show incorrectly on Disk Space Check Page.

Expected results: 
According to "the selected device" and "the configured partition sizes",
the label of "Available Space" and "Required Space" should show correct info on Disk Space Check Page.

Additional info: 
----------
Comment 1 haiyang,dong 2012-10-22 02:28:30 EDT
Created attachment 631271 [details]
Screenshot for Disk Space Check Page
Comment 3 Mike Burns 2012-12-13 11:45:51 EST
Upstream patch

http://gerrit.ovirt.org/10036
Comment 5 haiyang,dong 2012-12-24 00:59:06 EST
Using the build rhev-hypervisor6-6.4-20121212.1.auto1332.el6.iso to tried follow:
1. Select USB device(/dev/sdb 3821MB) to use for ROOT storage ROOT/HOSTVG_STORAGE.
2. Select  USB device(/dev/sdb) and USB device(/dev/sdc 7388MB) to use for HOSTVG storage.
3. Set Swap=4096MB Config=4096MB Logging=4096MB Data=4096MB on setting partition sizes page,
and click the "Continue" button.

it will prompt that "Available Space:11209MB" and "Required Space:16896MB" on Disk Space Check Page

So the "Available Space" is shown correctly(3821M+7388M), but failed for "Required Space".

actually the required space should be 17152MB(UEFI:256M+ROOT:256M+RootBackup:256M+Swap:4096M+Config:4096M+Logging:4096M+Data:4096M).

so need change the state into "assigned"
Comment 6 Mike Burns 2013-01-03 13:27:17 EST
The calculation was missing the EFI partition size.  It will now be included correctly.

http://gerrit.ovirt.org/10639
Comment 11 Mike Burns 2013-01-11 08:33:31 EST
It turns out that a later line was re-doing a calculation done earlier and wasn't taking EFI into account there.  I replaced that second calculation with the result of the first one.

http://gerrit.ovirt.org/10903
Comment 14 haiyang,dong 2013-01-21 07:16:39 EST
Test version:
rhev-hypervisor6-6.4-20130116.3.0.el6
ovirt-node-2.5.0-15.el6.noarch


1. 
(a). Select USB device(/dev/sdb 3821MB) to use for ROOT storage 
(b). Select  USB device(/dev/sdb) to use for HOSTVG storage.
(c). Set Swap=2000MB Config=2000MB Logging=2000MB Data=2000MB on setting partition sizes page,
and click the "Continue" button.

it will prompt that "Available Space:3821MB" and "Required Space:8768MB" on Disk Space Check Page

2. 
(a). Select USB device(/dev/sdb 3821MB) to use for ROOT storage .
(b). Select USB device(/dev/sdb) and USB device(/dev/sdc 3827MB) to use for HOSTVG storage.
(c). Set Swap=2000MB Config=2000MB Logging=2000MB Data=2000MB on setting partition sizes page,
and click the "Continue" button.

it will prompt that "Available Space:7648MB" and "Required Space:8768MB" on Disk Space Check Page

So this bug has been fixed,change the status into “VERIFIED”
Comment 16 errata-xmlrpc 2013-02-28 11:42:00 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.