Bug 868826 - wireless network profile behaves incorrectly when wifi turned off/on in gnome-shell applet
wireless network profile behaves incorrectly when wifi turned off/on in gnome...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: control-center (Show other bugs)
7.0
All Linux
unspecified Severity low
: beta
: 7.0
Assigned To: Richard Hughes
Desktop QE
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-22 04:45 EDT by Vladimir Benes
Modified: 2015-11-19 03:23 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 03:23:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladimir Benes 2012-10-22 04:45:00 EDT
Description of problem:
when I go into wireless profile in control-center Network tool there is a button that is used for (dis)connecting to a network. After turning off wifi from gnome-shell applet this button never turns back from grayed out state. You need to go back to profiles (networks) overview and then back to profile to be able to use it again.
What is even more broken is that after connecting back to the opened profile network that profile in control-center dialog says Out of range. When I go back to overview and back everything is OK again.

Version-Release number of selected component (if applicable):
NetworkManager-0.9.7.0-4.git20121004.el7.x86_64
control-center-3.6.0-1.el7.x86_64
gnome-shell-3.6.0-1.fc18.x86_64

How reproducible:
100%

Steps to Reproduce:
0.connect to a wireless network so you have a profile stored 
1.in the profile unset connect automatically (via nm-connection-editor)   
2.go into control-center Network dialog
3.go into the profile and leave the dialog open
4.in gnome-shell nm applet turn wifi off 
5.reenable wifi in the applet again
6.connect to the network via Network dialog
   
Actual results:
buttons greyed out. have to go to overview and back to profile to be able to connect 

Expected results:
profile state should be updated correctly

Additional info:
Comment 1 Richard Hughes 2013-05-09 11:07:21 EDT
Can you retest with control-center-3.8.*, a lot has changed in a minor version update. Thanks.
Comment 2 RHEL Product and Program Management 2014-03-22 03:04:48 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 Tomas Pelka 2015-05-14 06:10:15 EDT
I haven't met this issue with control-center-3.14.4-2.el7, I think this is fixed by the rebase.

Thanks
Tom
Comment 10 errata-xmlrpc 2015-11-19 03:23:27 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2157.html

Note You need to log in before you can comment on or make changes to this bug.