Bug 868829 - The "scale your application" page for scalable app displayed not well on Chrome21 and IPad2.
The "scale your application" page for scalable app displayed not well on Chro...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Steve Goodwin
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-22 04:47 EDT by Mengjiao Gao
Modified: 2015-05-14 21:15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 13:48:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
"scale your application" page displayed not well on Chrome21. (168.26 KB, image/png)
2012-10-22 04:47 EDT, Mengjiao Gao
no flags Details
Display on IPad2. (119.16 KB, image/png)
2012-10-24 01:14 EDT, Yujie Zhang
no flags Details
A little overlapped area in the page. (195.77 KB, image/png)
2012-10-30 01:06 EDT, Mengjiao Gao
no flags Details
Screenshot not replicating overlap issue (153.04 KB, image/png)
2012-10-30 12:43 EDT, Steve Goodwin
no flags Details
A little overlapped area on Chrome22.0.1229.94 on Fedora16(i386) (154.24 KB, image/png)
2012-10-30 22:08 EDT, Mengjiao Gao
no flags Details
A little overlapped area on Chrome22.0.1229.94 on RHEL6.2 (i386,virt machine) (132.83 KB, image/png)
2012-10-30 22:17 EDT, Mengjiao Gao
no flags Details

  None (edit)
Description Mengjiao Gao 2012-10-22 04:47:40 EDT
Created attachment 631331 [details]
"scale your application" page displayed not well on Chrome21.

Description of problem:
The "scale your application" page for scalable app displayed not well on Chrome21 as the attachment shown.

Version-Release number of selected component (if applicable):
devenv_2360

How reproducible:
always

Steps to Reproduce:
1.Create a scalable app via CLI:
$rhc app create -s -a appname -t python-2.6
2.Go to the website and login with the same account used in step 1
3.Go to the app page, and click the "Scaled up with HAProxy" button.
  
Actual results:
The following "scale your application" page displayed not well on Chrome21.

Expected results:
The page should displayed well.

Additional info:
This page displayed well on Firefox16 ,IE9 and safari.
Comment 1 Yujie Zhang 2012-10-24 01:11:55 EDT
Tested on devenv_2370 today, and the issue also exists on Safari5 on IPad2.
Comment 2 Yujie Zhang 2012-10-24 01:14:00 EDT
Created attachment 632545 [details]
Display on IPad2.
Comment 3 Xiaoli Tian 2012-10-29 23:53:40 EDT
(In reply to comment #2)
> Created attachment 632545 [details]
> Display on IPad2.

Move it to ON_QA to verify since pull request is merged in devenv_2403:
https://github.com/openshift/origin-server/pull/782
Comment 4 Mengjiao Gao 2012-10-30 01:04:28 EDT
Tested this issue on devenv_2403, found that the "scale your application" page have been changed to the new style. But there's still a little overlapped area between the min gear and max gear setting boxes as the attachment shown.
Comment 5 Mengjiao Gao 2012-10-30 01:06:22 EDT
Created attachment 635316 [details]
A little overlapped area in the page.
Comment 6 Steve Goodwin 2012-10-30 12:42:02 EDT
Tested this issue using Chrome 22 on both Mac and Linux could not replicate comment 4. Attaching my screenshot.

Is this on a windows platform?
Comment 7 Steve Goodwin 2012-10-30 12:43:05 EDT
Created attachment 635690 [details]
Screenshot not replicating overlap issue
Comment 8 Mengjiao Gao 2012-10-30 22:08:57 EDT
Created attachment 635897 [details]
A little overlapped area on Chrome22.0.1229.94 on Fedora16(i386)
Comment 9 Mengjiao Gao 2012-10-30 22:17:42 EDT
Created attachment 635898 [details]
A little overlapped area on Chrome22.0.1229.94 on RHEL6.2 (i386,virt machine)
Comment 10 Mengjiao Gao 2012-10-30 22:47:36 EDT
(In reply to comment #6)
> Tested this issue using Chrome 22 on both Mac and Linux could not replicate
> comment 4. Attaching my screenshot.
> 
> Is this on a windows platform?

My screenshot yesterday is using Chrome22 on Fedora16(i386) on devenv_2403.

I have tested this on devenv_2409 and INT(same with devenv_2409) today using  Chrome22 on Fedora16(i386),RHEL6.2(i386,x86_64), also using Chrome22 and Safari on Mac Os.And all of them have the problem as my attachment shown.

I have noticed that the color of boxes in our screenshots have a little difference. So I think maybe we have tested this on different DevEnv version. I think you may reproduce the issue on the newest devenv or INT. Thanks for your working on it!
Comment 11 Xiaoli Tian 2012-10-31 22:00:19 EDT
According to comment 10, move it back to Assigned to attract attention
Comment 12 Steve Goodwin 2012-11-01 13:33:35 EDT
additional fix
commit d443886ded00d204d65758475cb21f3f84f99f95
Comment 13 Mengjiao Gao 2012-11-05 01:23:13 EST
Tested this issue on devenv_2427 on Chrome22 and Safari on Ipad2, the page displays well now. So, I will put it to verified.

Note You need to log in before you can comment on or make changes to this bug.