Bug 868834 - can't use package section in kickstart
can't use package section in kickstart
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
AcceptedBlocker
: Reopened
Depends On:
Blocks: F18Beta/F18BetaBlocker F18Betappc 867367
  Show dependency treegraph
 
Reported: 2012-10-22 05:10 EDT by Michal Kovarik
Modified: 2013-03-12 10:26 EDT (History)
8 users (show)

See Also:
Fixed In Version: anaconda-18.22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-08 04:13:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
working kickstart (576 bytes, text/plain)
2012-10-22 08:14 EDT, Kamil Páral
no flags Details
doesn't work (252 bytes, text/plain)
2012-10-24 03:08 EDT, Michal Kovarik
no flags Details
works (227 bytes, text/plain)
2012-10-24 03:09 EDT, Michal Kovarik
no flags Details
console.log (33.03 KB, text/plain)
2012-10-24 04:57 EDT, Michal Kovarik
no flags Details
console.log with nokill (65.29 KB, text/plain)
2012-10-24 06:32 EDT, Michal Kovarik
no flags Details
anaconda.log (6.35 KB, text/plain)
2012-10-24 06:33 EDT, Michal Kovarik
no flags Details
program.log (50.81 KB, text/plain)
2012-10-24 06:33 EDT, Michal Kovarik
no flags Details
storage.log (134.38 KB, text/plain)
2012-10-24 06:34 EDT, Michal Kovarik
no flags Details
syslog (59.58 KB, text/plain)
2012-10-24 06:34 EDT, Michal Kovarik
no flags Details
broken kickstart (899 bytes, text/plain)
2012-10-24 15:29 EDT, Kamil Páral
no flags Details

  None (edit)
Description Michal Kovarik 2012-10-22 05:10:27 EDT
Description of problem:
When I use package section in kickstart, anaconda shows up 'INSTALLATION SUMMARY' and then anaconda is immediately terminated.

Version-Release number of selected component (if applicable):
Fedora 18 Beta TC6
anaconda 18.19

How reproducible:
Always

Steps to Reproduce:
1. prepare kickstart with package section, eg:
%packages --nobase
%end
or 
%packages --default
%end
2. start installation, use prepared kickstart

   
Actual results:
anaconda shows up 'INSTALLATION SUMMARY'
anaconda is terminated

Expected results:
success installation

Additional info:
Could be related to bug 867367
Comment 1 Kamil Páral 2012-10-22 08:13:58 EDT
Michal, please upload anaconda logs (from /tmp) and your kickstart file. I just finished successful kickstarted minimal installation using anaconda 18.19.
Comment 2 Kamil Páral 2012-10-22 08:14:33 EDT
Created attachment 631447 [details]
working kickstart
Comment 3 Michal Kovarik 2012-10-24 03:08:02 EDT
Kamil, I can't upload anaconda logs because system is rebooted immediately. Your kickstart works for me, but when I used autopart, system is terminated.
Comment 4 Michal Kovarik 2012-10-24 03:08:51 EDT
Created attachment 632559 [details]
doesn't work
Comment 5 Michal Kovarik 2012-10-24 03:09:29 EDT
Created attachment 632560 [details]
works
Comment 6 Kamil Páral 2012-10-24 04:03:53 EDT
The kickstart should be enough for developers to try to reproduce, but if you want to help them, Michal, then run this in a virtual machine and redirect system output to a serial console (using "console=ttyS0 graphical" boot arguments). That way you can gather some information and provide it here. Thanks.

I think there are also some anaconda arguments to use remote syslog, so that you can send your logs to a different machine. I never tried that, though.
Comment 7 Michal Kovarik 2012-10-24 04:57:42 EDT
Created attachment 632623 [details]
console.log
Comment 8 Michal Kovarik 2012-10-24 06:32:59 EDT
Created attachment 632680 [details]
console.log with nokill
Comment 9 Michal Kovarik 2012-10-24 06:33:30 EDT
Created attachment 632684 [details]
anaconda.log
Comment 10 Michal Kovarik 2012-10-24 06:33:57 EDT
Created attachment 632685 [details]
program.log
Comment 11 Michal Kovarik 2012-10-24 06:34:23 EDT
Created attachment 632686 [details]
storage.log
Comment 12 Michal Kovarik 2012-10-24 06:34:54 EDT
Created attachment 632687 [details]
syslog
Comment 13 Kamil Páral 2012-10-24 15:29:24 EDT
Created attachment 632982 [details]
broken kickstart

Hmm, now I hit this too with the ks above.
Comment 14 Kamil Páral 2012-10-24 15:31:04 EDT
Proposing as F18 Blocker, but we seem to miss appropriate criterion.
Comment 15 Kamil Páral 2012-10-24 15:36:03 EDT
Oh, the kickstart I uploaded is the kickstart anaconda produces on default install (with just partitioning changes). So we have a criterion for it and it's Beta:
" The installer must be able to successfully complete a scripted installation, using the installer's preferred scripting system, which duplicates the default interactive installation as closely as possible "
https://fedoraproject.org/wiki/Fedora_18_Beta_Release_Criteria
Comment 16 Jesse Keating 2012-10-24 17:16:57 EDT
I'm not able to reproduce using Beta TC6 and either:

%packages --nobase
%end

or

%packages --default
%end

In both cases I get just @core selected and the install progresses into actually installing packages.

Kamil's problem should be a new bug, I think it has to do some something else in the kickstart data, not something to do with the %packages selection.

Closing this one as fixed.
Comment 17 Michal Kovarik 2012-10-25 02:21:12 EDT
Hi Jesse, 
did you try 'broken kickstart' or "doesn't work" from attachments? As I mention in comment 3, there is problem with autopart and package section in kickstart.

I have tried autopart without package section - works
I have tried native partitioning and package section - works
I have tried autopart and package section - doesn't work
Comment 18 Jesse Keating 2012-10-25 23:44:41 EDT
Figured out what was going on here.  Essentially it was a race condition that was triggered by the combos you listed.  A fix has been posted for review.
Comment 19 Adam Williamson 2012-10-29 14:55:52 EDT
Discussed at 2012-10-29 QA meeting acting as a blocker review meeting: http://meetbot.fedoraproject.org/fedora-meeting/2012-10-29/fedora-qa.2012-10-29-15.00.html . Accepted as a blocker per criterion cited in comment #15.
Comment 20 Jesse Keating 2012-10-29 15:23:59 EDT
Pushed into master, will be in the next build.
Comment 21 Fedora Update System 2012-10-31 22:52:08 EDT
anaconda-18.22-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.22-1.fc18
Comment 22 Fedora Update System 2012-11-01 14:28:04 EDT
Package anaconda-18.22-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.22-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17432/anaconda-18.22-1.fc18
then log in and leave karma (feedback).
Comment 23 Adam Williamson 2012-11-01 14:52:02 EDT
Michal, the fix should be in the smoke13 build: https://dl.fedoraproject.org/pub/alt/qa/18/20121031_f18b-smoke13/ . Can you re-test with that and mark this as VERIFIED if it works? Thanks!
Comment 24 Fedora Update System 2012-11-02 00:06:40 EDT
anaconda-18.23-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.23-1.fc18
Comment 25 Michal Kovarik 2012-11-02 03:09:30 EDT
I've re-tested this issue with broken kickstarts from attachment on smoke14. Installation finished successfully.
Moving to VERIFIED
Comment 26 Fedora Update System 2012-11-02 14:40:52 EDT
Package anaconda-18.23-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.23-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17509/anaconda-18.23-1.fc18
then log in and leave karma (feedback).
Comment 27 Fedora Update System 2012-11-02 21:06:11 EDT
anaconda-18.24-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.24-1.fc18
Comment 28 Fedora Update System 2012-11-05 20:41:18 EST
anaconda-18.25-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.25-1.fc18
Comment 29 Fedora Update System 2012-11-06 13:51:48 EST
Package anaconda-18.25-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.25-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17691/anaconda-18.25-1.fc18
then log in and leave karma (feedback).
Comment 30 Fedora Update System 2012-11-06 21:13:24 EST
anaconda-18.26-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.26-1.fc18
Comment 31 Adam Williamson 2012-11-07 19:00:55 EST
This was verified back in comment #25. setting back.
Comment 32 Adam Williamson 2012-11-08 04:13:56 EST
18.26 went stable. Closing. (Bodhi closing of bugs when updates go stable is currently broken).

Note You need to log in before you can comment on or make changes to this bug.