Bug 868836 - the language spoke use Chinese font for Japanese
the language spoke use Chinese font for Japanese
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-22 05:13 EDT by Akira TAGOH
Modified: 2012-11-23 00:35 EST (History)
7 users (show)

See Also:
Fixed In Version: anaconda-18.20-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-23 00:35:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (1.74 KB, patch)
2012-10-22 05:19 EDT, Akira TAGOH
no flags Details | Diff
the language list rendering comparison (446.89 KB, image/png)
2012-10-22 05:23 EDT, Akira TAGOH
no flags Details

  None (edit)
Description Akira TAGOH 2012-10-22 05:13:40 EDT
Description of problem:
Summary says it all, this happens because pango/fontconfig guesses the wrong font from a given character, particularly which is in the unified ideographs or so in Unicode.

Version-Release number of selected component (if applicable):
anaconda-18.19-1.fc18.x86_64

How reproducible:
always

Steps to Reproduce:
1.see the language list on the language spoke
2.
3.
  
Actual results:
unexpected Chinese font is used for Japanese

Expected results:
Japanese font should be used.

Additional info:
Comment 1 Akira TAGOH 2012-10-22 05:19:03 EDT
Created attachment 631345 [details]
proposed patch

This patch is to use the pango markup in GtkCellRendererText for nativeName.
Comment 2 Akira TAGOH 2012-10-22 05:23:08 EDT
Created attachment 631348 [details]
the language list rendering comparison

the left column is the one without the pango markup, i.e. the original, the middle column is with the pango markup. the right column is just a guideline to see what the language a row is for.

You can see the difference for Japanese at least.
Comment 3 Chris Lumens 2012-10-22 11:37:00 EDT
Wow, that is really subtle and I definitely never would have caught it.  Thanks a lot for the patch.  I will be pushing it shortly.
Comment 4 Adam Williamson 2012-11-23 00:35:41 EST
This bug looks to have been fixed for many anaconda builds now but missed being closed. If you find you are still experiencing it with Fedora 18 Beta (RC1) or later, please re-open the bug.

(This looks correct to me in Beta RC1.)

Note You need to log in before you can comment on or make changes to this bug.