This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 868872 - Unable to create org after katello-reset-dbs script using SAM WEBUI
Unable to create org after katello-reset-dbs script using SAM WEBUI
Status: CLOSED UPSTREAM
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Miroslav Suchý
Tazim Kolhar
:
Depends On:
Blocks: sam13-tracker 870526
  Show dependency treegraph
 
Reported: 2012-10-22 06:43 EDT by Tazim Kolhar
Modified: 2016-04-25 20:54 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-12 08:22:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Unable_to_create_org_error (98.14 KB, image/png)
2012-10-22 06:43 EDT, Tazim Kolhar
no flags Details

  None (edit)
Description Tazim Kolhar 2012-10-22 06:43:59 EDT
Created attachment 631395 [details]
Unable_to_create_org_error

Description of problem:
Unable to create org using WEB UI after executing katello-reset-dbs script

Version-Release number of selected component (if applicable):
# rpm -qa | grep katello
katello-selinux-1.1.2-1.el6.noarch
katello-cli-1.2.0-1.git.10.c749d42.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-configure-1.2.0-1.git.44.0bd8ebe.el6.noarch
katello-common-1.2.1-1.git.2.10b2e82.el6.noarch
katello-headpin-all-1.2.1-1.git.2.10b2e82.el6.noarch
katello-certs-tools-1.1.9-1.el6.noarch
katello-glue-candlepin-1.2.1-1.git.2.10b2e82.el6.noarch
katello-cli-common-1.2.0-1.git.10.c749d42.el6.noarch
katello-headpin-1.2.1-1.git.2.10b2e82.el6.noarch


How reproducible:

# yum install -y katello-headpin-all
# katello-configure --deployment=headpin



Steps to Reproduce:
1. /usr/share/katello/script/katello-reset-dbs to reset candlepin db
2. all the data including (orgs, envrionment, activation keys) is erased with
   availability to fresh login
3. Login to SAM WEBUI
4. Navigate, Administer -> Manage Org 
5. Create + New Org
6. Enter new org name and label.
7. A valid org should be created 

  
Actual results:
Fails to create org . errors attached

Expected results:
A successful Org should be created.

Additional info
Comment 2 Miroslav Suchý 2012-12-04 08:14:05 EST
Discussed here:
https://www.redhat.com/archives/katello-devel/2012-November/msg00003.html
Comment 3 Miroslav Suchý 2012-12-04 08:41:28 EST
https://github.com/Katello/katello/pull/1176
Comment 4 Tom McKay 2012-12-04 10:55:51 EST
  Branch: refs/heads/master
  Home:   https://github.com/Katello/katello
  Commit: 21d555c8a3d74c6255f3332324d95ed6b809962e
      https://github.com/Katello/katello/commit/21d555c8a3d74c6255f3332324d95ed6b809962e
  Author: Miroslav Suchý <msuchy@redhat.com>
  Date:   2012-12-04 (Tue, 04 Dec 2012)
Comment 5 Bryan Kearney 2013-06-07 14:20:00 EDT
Moving all POST bugs to ON_QA since we have delivered a puddle with the bugs.

Note You need to log in before you can comment on or make changes to this bug.