Bug 868877 - [3.3.0.4rhs-34.el6rhs.x86_64.rpm] geo-rep status gives N/A.
[3.3.0.4rhs-34.el6rhs.x86_64.rpm] geo-rep status gives N/A.
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.0
x86_64 Linux
urgent Severity urgent
: ---
: ---
Assigned To: Csaba Henk
Vijaykumar Koppad
:
: 870502 870503 (view as bug list)
Depends On:
Blocks: 811632 815035 873380
  Show dependency treegraph
 
Reported: 2012-10-22 07:05 EDT by Vijaykumar Koppad
Modified: 2014-08-24 20:49 EDT (History)
10 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0qa5
Doc Type: Bug Fix
Doc Text:
Previously, the Geo-replication feature used an improper socket path and displayed 'N/A' as the status. This led to the checkpointing feature not working as expected. Now the socket issues are handled well and the status is displayed appropriately.
Story Points: ---
Clone Of:
: 873380 (view as bug list)
Environment:
Last Closed: 2013-09-15 23:25:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijaykumar Koppad 2012-10-22 07:05:19 EDT
Description of problem: After upgrading to  version 3.3.0.4rhs-34.el6rhs.x86_64.rpm , the geo-rep status says N/A. This is because checkpoint service went down. I have tested again with 3.3.0.3rhs-33.el6rhs.x86_64.rpm. It worked fine. After the upgrade only it is happening consistently. 


Version-Release number of selected component (if applicable):3.3.0.4rhs-34.el6rhs.x86_64.rpm


How reproducible:Consistently 


Steps to Reproduce:
1.Start a geo-rep session between master(dist-rep) and slave(dist-rep) 
2.check geo-rep status 
3.
  
Actual results: status shows N/A


Expected results: It should show proper status. 


Additional info:
Comment 2 Csaba Henk 2012-10-31 08:34:02 EDT
N/A means that checkpoint service is not functional.

That happened because the change of the location of
unix domain sockets that are used for inter-component
communication has changed as of

https://code.engineering.redhat.com/gerrit/120

on the glusterd side, but gsyncd has not been
adjusted so the checkpoint service is not found
where glusterd expects it to be.

The proper fix is to have glusterd to specify
the socket location to gsyncd, instead of hardwiring
it into gsyncd code.
Comment 3 Csaba Henk 2012-11-19 14:32:13 EST
*** Bug 870503 has been marked as a duplicate of this bug. ***
Comment 4 Csaba Henk 2012-11-19 14:32:20 EST
*** Bug 870502 has been marked as a duplicate of this bug. ***
Comment 5 Vijay Bellur 2012-11-28 19:54:45 EST
CHANGE: http://review.gluster.org/4143 (geo-rep / gsyncd,glusterd: do not hardcode socket path) merged in master by Anand Avati (avati@redhat.com)
Comment 6 Pavithra 2013-08-26 03:10:57 EDT
Kindly verify the edited doc text for technical accuracy and sign off.
Comment 8 errata-xmlrpc 2013-09-15 23:25:45 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.