Bug 868884 - managing config channels through SSM unifies subscriptions for all the systems
managing config channels through SSM unifies subscriptions for all the systems
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: WebUI (Show other bugs)
1.8
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Lestach
Red Hat Satellite QA List
:
Depends On:
Blocks: 868886 space19
  Show dependency treegraph
 
Reported: 2012-10-22 07:19 EDT by Jan Hutař
Modified: 2013-03-06 13:35 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 868886 (view as bug list)
Environment:
Last Closed: 2013-03-06 13:35:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2012-10-22 07:19:53 EDT
Description of problem:
When you attempt to add configuration channel using SSM tool to systems with different configuration channel sets, you will end up with all systems with same set.


Version-Release number of selected component (if applicable):
spacewalk-java-1.8.165-1.el6.noarch


How reproducible:
always


Steps to Reproduce:
1. Have systemA subscribed in configuration channel A
   Have systemB subscribed in configuration channel B
   Have configuration channel C prepared
2. Select systemA and systemB to be managed through System Set Manager
3. In SSM click "Manage systems' config channel subscriptions", select
   conf. channel C to be added, select either:
    * Subscribe With Lowest Priority
   or:
    * Subscribe With Highest Priority
   and click "Apply Subscription", click "Confirm".


Actual results:
systemA subscribed in configuration channel A and B and C
systemB subscribed in configuration channel A and B and C


Expected results:
systemA subscribed in configuration channel A and C
systemB subscribed in configuration channel B and C
Comment 1 Jan Hutař 2012-10-22 07:21:31 EDT
This issue was initially reported with slightly more complex scenario by:

From: Baptiste AGASSE <baptiste.agasse@lyra-network.com>
To: spacewalk-list@redhat.com
Reply-To: spacewalk-list@redhat.com
Subject: [Spacewalk-list] Config channel management bug
Date: Wed, 3 Oct 2012 11:59:17 +0200 (CEST)
Sender: spacewalk-list-bounces@redhat.com

Thanks!
Comment 2 Tomas Lestach 2013-01-09 11:23:16 EST
spacewalk.git:
 35d36f75d2a888675b0be048e46dd1b391798ea2 (subscribe only to selected config channels via SSM)
 009cd32cca908c966ac36440f0de4b5fec7320d3 (fix the 'Replace Existing Subscriptions' SSM config channel option)
Comment 3 Stephen Herr 2013-03-01 12:08:03 EST
Marking bug as ON_QA since tonight's build of Spacewalk nightly is a release candidate for Spacewalk 1.9.
Comment 4 Stephen Herr 2013-03-06 13:35:43 EST
Spacewalk 1.9 has been released.

https://fedorahosted.org/spacewalk/wiki/ReleaseNotes19

Note You need to log in before you can comment on or make changes to this bug.