Bug 868888 - [rhevm-setup] ovirt-engine should be replaced with jbossas [TEXT]
[rhevm-setup] ovirt-engine should be replaced with jbossas [TEXT]
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.2.0
x86_64 Linux
medium Severity unspecified
: ---
: 3.2.0
Assigned To: Alex Lourie
Ilanit Stein
integration
: ZStream
Depends On:
Blocks: 891628
  Show dependency treegraph
 
Reported: 2012-10-22 07:24 EDT by Kiril Nesenko
Modified: 2014-07-10 20:09 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 891628 (view as bug list)
Environment:
Last Closed: 2013-02-18 05:37:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
upgrade log (242.42 KB, application/octet-stream)
2013-02-11 08:43 EST, Ilanit Stein
no flags Details

  None (edit)
Description Kiril Nesenko 2012-10-22 07:24:49 EDT
Description of problem:
While performing upgrade from 3.0 to 3.1 noticed:

[root@vm-18-170 yum.repos.d]# rhevm-upgrade 
Loaded plugins: product-id, rhnplugin
Info: RHEV Manager 3.0 to 3.1 upgrade detected
Checking pre-upgrade conditions...(This may take several minutes)

Warning: the following packages will be removed if you proceed with the upgrade:
 * pki-silent
 * objectweb-asm
 * tomcatjss
 * tomcat6-lib
 * pki-ca
 * xml-commons-resolver
 * pki-common
 * tomcat6
Would you like to proceed? (yes|no): yes
Checking for updates... (This may take several minutes)
13 Updates available:
 * rhevm-3.1.0-21.el6ev.noarch
 * rhevm-backend-3.1.0-21.el6ev.noarch
 * rhevm-config-3.1.0-21.el6ev.noarch
 * rhevm-dbscripts-3.1.0-21.el6ev.noarch
 * rhevm-genericapi-3.1.0-21.el6ev.noarch
 * rhevm-iso-uploader-3.1.0-5.el6ev.noarch
 * rhevm-log-collector-3.1.0-7.el6ev.noarch
 * rhevm-notification-service-3.1.0-21.el6ev.noarch
 * rhevm-restapi-3.1.0-21.el6ev.noarch
 * rhevm-tools-common-3.1.0-21.el6ev.noarch
 * rhevm-userportal-3.1.0-21.el6ev.noarch
 * rhevm-webadmin-portal-3.1.0-21.el6ev.noarch
 * vdsm-bootstrap-4.9.6-38.0.el6_3.noarch

During the upgrade process, RHEV Manager  will not be accessible.
All existing running virtual machines will continue but you will not be able to
start or stop any new virtual machines during the process.

Would you like to proceed? (yes|no): yes
Stopping ovirt-engine Service...                         [ DONE ]
Stopping DB related services...                          [ DONE ]
Pre-upgrade validations...                               [ DONE ]
Backing Up Database...                                   [ DONE ]

Stopping ovirt-engine Service... <- should be replaced with jbossas, because in this phase of upgrade there is no ovirt-engine service on the system.

Version-Release number of selected component (if applicable):
ic21.1

How reproducible:
Always

Steps to Reproduce:
1. Perform upgrade from 3.0 to 3.1
2.
3.
  
Actual results:
Stopping ovirt-engine Service...                         [ DONE ]

Expected results:
Stopping jbossas Service...                         [ DONE ]

Additional info:
Comment 3 Moran Goldboim 2012-12-20 07:30:58 EST
test only. 3.0->3.1 upgrade flow
Comment 5 Ilanit Stein 2013-02-11 08:40:19 EST
Upgrade log from ic158.2 to si27 include a mix of ovirt-engine and jbossas (attached). 

For example:

ovirt-engine service is up and running   <=== "ovirt-engine"
2013-02-11 08:49:25::DEBUG::common_utils::909::root:: asking user: Would you like to proceed? (yes|no):
2013-02-11 08:49:27::DEBUG::common_utils::913::root:: user answered: yes
2013-02-11 08:49:27::DEBUG::rhevm-upgrade::644::root:: stopping jbossas service.
2013-02-11 08:49:27::DEBUG::common_utils::339::root:: Executing command --> '/sbin/service jbossas stop'
2013-02-11 08:49:37::DEBUG::common_utils::377::root:: output = Stopping jbossas: [  OK  ]  <=== "jbossas"

Could you please check it?

Thanks,
Ilanit.
Comment 6 Ilanit Stein 2013-02-11 08:43:48 EST
Created attachment 696089 [details]
upgrade log
Comment 7 Ilanit Stein 2013-02-12 02:48:57 EST
Verified on upgrade from ic158.2 to ic158.2:

[root@lilach-rhel-30 ~]# rhevm-upgrade
Loaded plugins: product-id, rhnplugin, versionlock
Repository rhel-source is listed more than once in the configuration
Repository rhel-source-beta is listed more than once in the configuration
Checking for updates... (This may take several minutes)
1 Updates available:
 * rhevm-admin-portal-wpf-3.0-53.el6ev.noarch

During the upgrade process, RHEV Manager will not be accessible.
All existing running virtual machines will continue but you will not be able to
start or stop any new virtual machines during the process.

Would you like to proceed? (yes|no): yes
Stopping JBoss Service...                                [ DONE ]
Updating rpms...                                         [ DONE ]
Updating JBoss Profile...                                [ DONE ]
Running post install configuration...                    [ DONE ]
Starting JBoss...                                        [ DONE ]

RHEV Manager upgrade completed successfully!

* Upgrade log available at /var/log/rhevm/rhevm-upgrade_2013_02_12_21_45_20.log
Comment 8 Ilanit Stein 2013-02-12 03:48:22 EST
Found on upgrade ic158.2 to si27 "Stopping ovirt-engine service" test still appear:

[root@lilach-rhel-30 yum.repos.d]# rhevm-upgrade
Loaded plugins: product-id, rhnplugin
Repository rhel-source is listed more than once in the configuration
Repository rhel-source-beta is listed more than once in the configuration
Info: RHEV Manager 3.0 to 3.1 upgrade detected
Checking pre-upgrade conditions...(This may take several minutes)

Warning: the following packages will be removed if you proceed with the upgrade:
 * objectweb-asm
Would you like to proceed? (yes|no): yes

Checking for updates... (This may take several minutes)
13 Updates available:
 * rhevm-3.1.0-46.el6ev.noarch
 * rhevm-backend-3.1.0-46.el6ev.noarch
 * rhevm-config-3.1.0-46.el6ev.noarch
 * rhevm-dbscripts-3.1.0-46.el6ev.noarch
 * rhevm-genericapi-3.1.0-46.el6ev.noarch
 * rhevm-iso-uploader-3.1.0-9.el6ev.noarch
 * rhevm-log-collector-3.1.0-10.el6ev.noarch
 * rhevm-notification-service-3.1.0-46.el6ev.noarch
 * rhevm-restapi-3.1.0-46.el6ev.noarch
 * rhevm-tools-common-3.1.0-46.el6ev.noarch
 * rhevm-userportal-3.1.0-46.el6ev.noarch
 * rhevm-webadmin-portal-3.1.0-46.el6ev.noarch
 * vdsm-bootstrap-4.10.2-1.3.el6.noarch

During the upgrade process, RHEV Manager  will not be accessible.
All existing running virtual machines will continue but you will not be able to
start or stop any new virtual machines during the process.

Would you like to proceed? (yes|no): yes
Stopping ovirt-engine service...                         [ DONE ]
Stopping DB related services...                          [ DONE ]
Pre-upgrade validations...                               [ DONE ]
Preparing system for 3.1 upgrade...                      [ DONE ]
Backing Up Database...                                   [ DONE ]
Rename Database...                                       [ DONE ]
Updating rpms (This may take a while
depending on your connection speed to the repository.
To track the installation process run tail -f /var/log/yum.log in another session).
Note that the transition from package removal to package installation is expected
to take a significant amount of time. No output will appear in the log file during
this transition....yum update rhevm-setup
Comment 9 Alex Lourie 2013-02-18 05:37:19 EST
this change is relevant only for 3.0->3.1 upgrade.
since it was closed for 3.1 is closed for 3.2 as well

Note You need to log in before you can comment on or make changes to this bug.