This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 868889 - rhevm-config help: Need to make cver optional and note that if version is not "general" it must be given.
rhevm-config help: Need to make cver optional and note that if version is not...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-config (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.2.0
Assigned To: Ravi Nori
Pavel Stehlik
infra
:
Depends On:
Blocks: 915537
  Show dependency treegraph
 
Reported: 2012-10-22 07:33 EDT by Ilanit Stein
Modified: 2016-02-10 14:40 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ilanit Stein 2012-10-22 07:33:53 EDT
Description of problem:

On rhevm-config (SI20) -help "cver" option description, "The cver version is mandatory for this action.", need to be changed since it is true only for some of the configuration keys. We need to make cver optional and note that if version is not "general" it must be given.
Comment 1 Yair Zaslavsky 2012-10-22 08:17:38 EDT
Altough it doesn't sound too risky/too complex to solve, not sure if in the current timeframe of 3.1, we should fix this. This is not a blocker bug.
Comment 2 Itamar Heim 2012-10-24 01:14:52 EDT
shouldn't user specify 'general' as cver?
Comment 3 Ilanit Stein 2012-10-24 02:39:12 EDT
'general' is the default cver. 
In case --cver option is not used, cver general is chosen. 
This bug asks to be accurate in the help cver option definition. 
cver is mandatory only for the non-general configuration key.
Comment 4 Ravi Nori 2012-10-24 13:34:40 EDT
Link: http://gerrit.ovirt.org/#/c/8787/

Commit Hash: d660b7888dec1fb1867acf6c4df3fa55d1d28cdc
Comment 5 Oded Ramraz 2013-01-24 11:04:15 EST
From the help : "set the value of the given key for the given version. The cver version is required for this action only when the version is not 'general'."

Verified sf4
Comment 6 Itamar Heim 2013-06-11 04:40:31 EDT
3.2 has been released
Comment 7 Itamar Heim 2013-06-11 04:40:31 EDT
3.2 has been released
Comment 8 Itamar Heim 2013-06-11 04:40:46 EDT
3.2 has been released
Comment 9 Itamar Heim 2013-06-11 04:48:09 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.