Bug 8689 - gnome-terminal plays poorly with less(1)
gnome-terminal plays poorly with less(1)
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
6.1
All Linux
medium Severity high
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-20 21:36 EST by Stig Hackvan
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-03 14:19:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stig Hackvan 2000-01-20 21:36:46 EST
on a gnome-terminal, if you 'less' a small file, you get a screenful of
rubbish from the last program to use the alternate screen image (the last
invocation of less, for instance).

if you do the same thing on an xterm, the alternate screen is not used and
you can see that the file is short because the prompt doesn't roll off the
screen...you have context.

the behavior of less is severely broken on gnome-terminal.

gnome terminal should either behave like xterm (it says it's an xterm) or
it should have a different term{cap,info} entry...
Comment 1 Havoc Pennington 2000-02-03 14:19:59 EST
I don't get a screenful of rubbish in the latest stuff, though the behavior is
somewhat different
(gnome-terminal clears the screen before entering less, xterm does not).
Either behavior is sane though so I think a separate terminfo entry
would just be inconvenient. Will reopen the bug if I can reproduce
the rubbish.

Note You need to log in before you can comment on or make changes to this bug.