Bug 868902 - Jobs forever queued
Jobs forever queued
Status: CLOSED DUPLICATE of bug 701254
Product: Beaker
Classification: Community
Component: scheduler (Show other bugs)
0.9
Unspecified Unspecified
unspecified Severity low (vote)
: ---
: ---
Assigned To: Dan Callaghan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-22 08:28 EDT by Petr Beňas
Modified: 2018-02-05 19:41 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-22 19:52:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Beňas 2012-10-22 08:28:11 EDT
Description of problem:
Sometimes jobs stay in queued state forever. When rescheduling such job, the newer job is picked and the old one not. 

Version-Release number of selected component (if applicable):
0.9.4

How reproducible:
Occasionally, usually when testing 5.3.LL virt (about 40 jobs submitted in short time). 

Steps to Reproduce:
Unknown
  
Actual results:
Jobs in queued state forever (even with high priority).

Expected results:
Oldest jobs with same priority are picked first and no jobs are queued forever.

Additional info:
Examples of forever queued jobs
https://beaker.engineering.redhat.com/jobs/310815
https://beaker.engineering.redhat.com/jobs/310814
https://beaker.engineering.redhat.com/jobs/310288

Probably different issue than bug 668473.
Comment 1 Dan Callaghan 2012-10-22 19:52:43 EDT
I'm fairly sure this is the same as bug 701254, which is that the guest recipes are scheduled first into a smaller lab which does not contain any systems which match the host recipe.

This will be solved with bug 655009, since we won't be scheduling guest recipes anymore.

*** This bug has been marked as a duplicate of bug 701254 ***

Note You need to log in before you can comment on or make changes to this bug.