Bug 868904 - Cannot add system to systemgroup (or apparently do anything with pulp at all)
Cannot add system to systemgroup (or apparently do anything with pulp at all)
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Partha Aji
Katello QA List
: Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-22 08:31 EDT by Jeff Weiss
Modified: 2014-11-09 17:52 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-18 13:37:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
zipped logs (263.28 KB, application/x-gzip)
2012-10-22 08:31 EDT, Jeff Weiss
no flags Details

  None (edit)
Description Jeff Weiss 2012-10-22 08:31:53 EDT
Created attachment 631462 [details]
zipped logs

Description of problem:
Something happens to the state of katello where you can no longer add systems to system groups.  Also syncs seem to fail after this (and possibly every single call to pulp).  The pulp logs show nothing above INFO level log entries, nothing useful there.

Version-Release number of selected component (if applicable):
Katello Version: 1.2.1-1.git.122.8b1c3a7.el6_3

How reproducible:
Not very.  Things work fine for a while (including the adding system to the same system group), and then something happens, after which all the pulp calls fail.  See attached logs.  

Steps to Reproduce:
1. Log in 
2. ??
3. Profit
4. Add system to system group
  
Actual results:
Error notification 

Resources::Pulp::ConsumerGroup: 401 Unauthorized "Permission Denied" (POST /pulp/api/consumergroups/ACME_Corporation-fed-1022-080149-926-eb191010/add_consumer/) (RestClient::Unauthorized)
    "Permission Denied"
    Click here for more details.

Expected results:
Successful add

Additional info:
Comment 5 Mike McCune 2014-03-18 13:37:07 EDT
This bug was closed because of a lack of activity.  If you feel this bug should be reconsidered for attention please feel free to re-open the bug with a comment stating why it should be reconsidered.

Note You need to log in before you can comment on or make changes to this bug.