Bug 868906 - Users with i18n names are rejected because of foreman
Users with i18n names are rejected because of foreman
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.1
Unspecified Unspecified
low Severity medium (vote)
: Unspecified
: --
Assigned To: Amos Benari
Og Maciel
: Regression, TestBlocker, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-22 08:39 EDT by Jeff Weiss
Modified: 2014-11-09 17:52 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 17:18:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Weiss 2012-10-22 08:39:47 EDT
Description of problem:


Version-Release number of selected component (if applicable):
Katello Version: 1.2.1-1.git.122.8b1c3a7.el6_3

How reproducible:
always

Steps to Reproduce:
1. Create user named "Гесер"
2. 
3.
  
Actual results:
Foreman::User is invalid:
- Login is invalid (Resources::AbstractModel::Invalid)

Expected results:
user created

Additional info:
Comment 4 Corey Welton 2013-06-14 10:48:36 EDT
Related, when entering a username with multibyte chars (i.e., "你好你好"), UI returns following warning:

Failed to perform additional action KatelloForemanEngine::Actions::UserCreate: 422 Unprocessable Entity
Comment 6 Amos Benari 2013-06-17 06:10:42 EDT
upstream reference bug is: 
 http://projects.theforeman.org/issues/2669
 username first name and last name doesn't accept i18n characters

fix posted upstream to:
 https://github.com/theforeman/foreman/pull/723
Comment 7 Sam Kottler 2013-06-18 16:40:56 EDT
This should not be on POST. It should be moved to POST only after the pull request is ready for cherry-pick.
Comment 8 Mike McCune 2013-06-20 00:41:39 EDT
looks like it did get merged, can move to POST
Comment 9 Amos Benari 2013-06-20 03:05:35 EDT
merged as 
https://github.com/theforeman/foreman/commit/aa925f8
Comment 10 Dominic Cleal 2013-06-20 03:43:33 EDT
Merged into 1.2-stable as:

commit be6631e03b8161229d15257334df7f6a68e1106d
    fixes #2669 username first name and last name doesn't accept i18n characters
Comment 11 Brad Buckingham 2013-06-21 08:59:46 EDT
Mass move to ON_QA
Comment 12 Og Maciel 2013-06-22 17:16:08 EDT
Verified:
* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.9-1.el6_4.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.9-1.el6_4.noarch
* candlepin-tomcat6-0.8.9-1.el6_4.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.1.10014-1.noarch
* foreman-compute-1.1.10014-1.noarch
* foreman-installer-puppet-concat-0-2.d776701.git.0.21ef926.el6sat.noarch
* foreman-installer-puppet-dhcp-0-5.3a4a13c.el6sat.noarch
* foreman-installer-puppet-dns-0-7.fcae203.el6sat.noarch
* foreman-installer-puppet-foreman-0-6.568c5c4.el6sat.noarch
* foreman-installer-puppet-foreman_proxy-0-8.bd1e35d.el6sat.noarch
* foreman-installer-puppet-puppet-0-3.ab46748.el6sat.noarch
* foreman-installer-puppet-tftp-0-5.ea6c5e5.el6sat.noarch
* foreman-installer-puppet-xinetd-0-50a267b8.git.0.44aca6a.el6sat.noarch
* foreman-libvirt-1.1.10014-1.noarch
* foreman-postgresql-1.1.10014-1.noarch
* foreman-proxy-1.1.10003-1.el6sat.noarch
* foreman-proxy-installer-1.0.1-10.f5ae2cd.el6sat.noarch
* katello-1.4.2-17.el6sat.noarch
* katello-all-1.4.2-17.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.2-8.el6sat.noarch
* katello-cli-common-1.4.2-8.el6sat.noarch
* katello-common-1.4.2-17.el6sat.noarch
* katello-configure-1.4.3-16.el6sat.noarch
* katello-configure-foreman-1.4.3-16.el6sat.noarch
* katello-foreman-all-1.4.2-17.el6sat.noarch
* katello-glue-candlepin-1.4.2-17.el6sat.noarch
* katello-glue-elasticsearch-1.4.2-17.el6sat.noarch
* katello-glue-pulp-1.4.2-17.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.3-3.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* pulp-rpm-plugins-2.1.2-1.el6sat.noarch
* pulp-selinux-2.1.2-1.el6sat.noarch
* pulp-server-2.1.2-1.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-1.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-2.el6sat.noarch
* ruby193-rubygem-runcible-0.4.10-1.el6sat.noarch
* signo-0.0.19-1.el6sat.noarch
* signo-katello-0.0.19-1.el6sat.noarch
Comment 13 Mike McCune 2013-07-18 17:18:20 EDT
mass move to CLOSED:CURRENTRELEASE since MDP1 has been released.
Comment 14 Mike McCune 2013-08-16 14:10:35 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.