Bug 868911 - From RHSC, when trying to "import existing cluster" that consists of a single machine, it is not able to import.
From RHSC, when trying to "import existing cluster" that consists of a single...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.0
All All
low Severity low
: ---
: ---
Assigned To: Vinayaga Raman
Shruti Sampat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-22 08:46 EDT by Shruti Sampat
Modified: 2014-03-30 21:29 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:25:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shruti Sampat 2012-10-22 08:46:58 EDT
Description of problem:
---------------------------------------
From RHSC, when using the "Import existing gluster configuration" feature, to import a cluster that consists of a single host, the GUI hangs. 


Version-Release number of selected component (if applicable):
2.0.techpreview2-0.63.20121019gitffbe992.root.el6ev

How reproducible:
Always reproducible

Steps to Reproduce:
1.Click on 'Clusters' tab.
2.Click on 'New'
3.Enter 'Name' and 'Description' and check the 'Import existing gluster configuration' check-box and enter the host details that needs to be imported as a cluster.

The following is seen in the engine logs - 
---------------------------------------
2012-10-22 17:32:26,884 WARN  [org.ovirt.engine.core.dal.dbbroker.generic.DBConfigUtils] (ajp-/127.0.0.1:8702-3) Adding new value to configuration cache.
2012-10-22 17:32:26,884 WARN  [org.ovirt.engine.core.dal.dbbroker.generic.DBConfigUtils] (ajp-/127.0.0.1:8702-3) Didnt find the value of GlusterPeerStatusCommand in DB for version general - using default: gluster peer status --xml
2012-10-22 17:32:27,306 ERROR [org.ovirt.engine.core.bll.gluster.GetGlusterServersQuery] (ajp-/127.0.0.1:8702-3) Query GetGlusterServersQuery failed. Exception message is org.xml.sax.SAXParseException; lineNumber: 1; columnNumber: 1; Content is not allowed in prolog.
2012-10-22 17:35:00,001 INFO  [org.ovirt.engine.core.bll.AutoRecoveryManager] (QuartzScheduler_Worker-13) Autorecovering hosts is disabled, skipping
2012-10-22 17:35:00,001 INFO  [org.ovirt.engine.core.bll.AutoRecoveryManager] (QuartzScheduler_Worker-13) Autorecovering storage domains is disabled, skipping

Actual results:
GUI hangs.

Expected results:
The host should be successfully added as cluster.

Additional info:
Comment 2 Dhandapani 2012-12-07 01:58:42 EST
This issue seems to be fixed with the latest QA drop.
Comment 3 Shruti Sampat 2012-12-10 00:55:37 EST
Verified in Red Hat Storage Console Version: 2.1-qa18.el6ev
Comment 5 Scott Haines 2013-09-23 18:25:22 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.