Bug 868912 - Enable support for persistent queues in gearmand
Enable support for persistent queues in gearmand
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: gearmand (Show other bugs)
el5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: BJ Dierkes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-22 08:52 EDT by Nils Breunese
Modified: 2013-08-07 14:13 EDT (History)
2 users (show)

See Also:
Fixed In Version: gearmand-1.1.8-2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-07 14:12:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nils Breunese 2012-10-22 08:52:36 EDT
Description of problem:

According to http://gearman.org/index.php?id=manual:job_server#persistent_queues gearmand has support for persistent queues: "Inside the Gearman job server, all job queues are stored in memory. This means if a server restarts or crashes with pending jobs, they will be lost and are never run by a worker. Persistent queues were added to allow background jobs to be stored in an external durable queue so they may live between server restarts and crashes. (...) Persistent queues were a new feature added in version 0.6 of the job server. The queues are implemented using a modular interface so it is easy to add new data stores for the persistent queue."

It seems the gearmand 0.14 package distributed currently has no support for persistent queues enabled.

Version-Release number of selected component (if applicable):

gearmand-0.14-3.el5.x86_64

Steps to Reproduce:
1. Install the libdrizzle and sqlite packages for the libdrizzle and libsqlite3 libraries: # yum install libdrizzle sqlite
2. Try to start gearmand with libdrizzle: gearmand -q libdrizzle -vvv -u root
3. Try to start gearmand with libsqlite3: gearmand -q libsqlite3 -vvv -u root
  
Actual results:

Error messages saying the queue module is unknown:

----
gearmand: Unknown queue module: libdrizzle
----

----
gearmand: Unknown queue module: libsqlite
----

Expected results:

No error messages.

Additional info:

It would also be nice if gearmand could be updated to a recent release from upstream for bug fixes. Version 0.14 was released on 2010-07-01. Version 0.41 (2012-10-12) is currently the latest version in the 1.0 series according to https://launchpad.net/gearmand/+series and the latest version in the 1.2 series is 1.1.2 (2012-10-12).
Comment 1 Fedora Update System 2013-07-22 14:45:15 EDT
gearmand-1.1.8-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/gearmand-1.1.8-2.el6
Comment 2 Fedora Update System 2013-07-22 15:05:17 EDT
gearmand-1.1.8-2.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/gearmand-1.1.8-2.el5
Comment 3 Fedora Update System 2013-07-22 17:46:18 EDT
Package gearmand-1.1.8-2.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing gearmand-1.1.8-2.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-10921/gearmand-1.1.8-2.el6
then log in and leave karma (feedback).
Comment 4 Pim Rupert (Lemonbit) 2013-08-05 10:14:28 EDT
Thank you. Works for me. Karma left.
Comment 5 Fedora Update System 2013-08-07 14:12:18 EDT
gearmand-1.1.8-2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2013-08-07 14:12:57 EDT
gearmand-1.1.8-2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.