Bug 868925 - BootLoaderError: bootloader install failed
BootLoaderError: bootloader install failed
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
abrt_hash:6ef44e78f53fd8e7f2d8453d6df...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-22 09:29 EDT by Thomas Woerner
Modified: 2013-04-01 12:36 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-01 12:36:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: ifcfg.log (641 bytes, text/plain)
2012-10-22 09:29 EDT, Thomas Woerner
no flags Details
File: anaconda-tb (4.59 MB, text/plain)
2012-10-22 09:29 EDT, Thomas Woerner
no flags Details
File: product (6 bytes, text/plain)
2012-10-22 09:29 EDT, Thomas Woerner
no flags Details
File: type (9 bytes, text/plain)
2012-10-22 09:29 EDT, Thomas Woerner
no flags Details
File: environ (777 bytes, text/plain)
2012-10-22 09:29 EDT, Thomas Woerner
no flags Details
File: storage.log (84.63 KB, text/plain)
2012-10-22 09:29 EDT, Thomas Woerner
no flags Details
File: version (11 bytes, text/plain)
2012-10-22 09:29 EDT, Thomas Woerner
no flags Details
File: program.log (4.15 MB, text/plain)
2012-10-22 09:30 EDT, Thomas Woerner
no flags Details
File: anaconda.log (12.74 KB, text/plain)
2012-10-22 09:30 EDT, Thomas Woerner
no flags Details
File: syslog (59.31 KB, text/plain)
2012-10-22 09:30 EDT, Thomas Woerner
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-22 09:30 EDT, Thomas Woerner
no flags Details
File: packaging.log (243.84 KB, text/plain)
2012-10-22 09:30 EDT, Thomas Woerner
no flags Details
File: cmdline_file (96 bytes, text/plain)
2012-10-22 09:30 EDT, Thomas Woerner
no flags Details
File: release (24 bytes, text/plain)
2012-10-22 09:30 EDT, Thomas Woerner
no flags Details

  None (edit)
Description Thomas Woerner 2012-10-22 09:29:10 EDT
Version-Release number of selected component:
anaconda-18.19

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.1-1.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.19 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1531, in install
:    raise BootLoaderError("bootloader install failed")
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1542, in write
:    self.install()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 2213, in writeBootLoader
:    storage.bootloader.write()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 128, in doInstall
:    writeBootLoader(storage, payload, instClass)
:  File "/usr/lib64/python2.7/threading.py", line 504, in run
:    self.__target(*self.__args, **self.__kwargs)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 91, in run
:    threading.Thread.run(self, *args, **kwargs)
:BootLoaderError: bootloader install failed
Comment 1 Thomas Woerner 2012-10-22 09:29:14 EDT
Created attachment 631515 [details]
File: ifcfg.log
Comment 2 Thomas Woerner 2012-10-22 09:29:32 EDT
Created attachment 631516 [details]
File: anaconda-tb
Comment 3 Thomas Woerner 2012-10-22 09:29:35 EDT
Created attachment 631517 [details]
File: product
Comment 4 Thomas Woerner 2012-10-22 09:29:37 EDT
Created attachment 631518 [details]
File: type
Comment 5 Thomas Woerner 2012-10-22 09:29:39 EDT
Created attachment 631519 [details]
File: environ
Comment 6 Thomas Woerner 2012-10-22 09:29:41 EDT
Created attachment 631520 [details]
File: storage.log
Comment 7 Thomas Woerner 2012-10-22 09:29:42 EDT
Created attachment 631521 [details]
File: version
Comment 8 Thomas Woerner 2012-10-22 09:30:00 EDT
Created attachment 631522 [details]
File: program.log
Comment 9 Thomas Woerner 2012-10-22 09:30:03 EDT
Created attachment 631523 [details]
File: anaconda.log
Comment 10 Thomas Woerner 2012-10-22 09:30:05 EDT
Created attachment 631524 [details]
File: syslog
Comment 11 Thomas Woerner 2012-10-22 09:30:08 EDT
Created attachment 631525 [details]
File: hashmarkername
Comment 12 Thomas Woerner 2012-10-22 09:30:14 EDT
Created attachment 631526 [details]
File: packaging.log
Comment 13 Thomas Woerner 2012-10-22 09:30:16 EDT
Created attachment 631527 [details]
File: cmdline_file
Comment 14 Thomas Woerner 2012-10-22 09:30:18 EDT
Created attachment 631528 [details]
File: release
Comment 15 Chris Lumens 2012-10-22 10:46:51 EDT
15:11:47,731 ERR program: /usr/sbin/grub2-bios-setup: warning: this GPT partition label contains no BIOS Boot Partition; embedding won't be possible.
15:11:47,737 ERR program: /usr/sbin/grub2-bios-setup: warning: Embedding is not possible.  GRUB can only be installed in this setup by using blocklists.  However, blocklists are UNRELIABLE and their use is discouraged..
15:11:47,738 ERR program: /usr/sbin/grub2-bios-setup: error: will not proceed with blocklists.
Comment 16 Thomas Woerner 2012-10-22 13:08:12 EDT
The reason for this might be the size of '/'. It was bigger than 2T. See #868899 for a way to reproduce (comment 2 point 3).
Comment 17 Tim Flink 2012-10-22 18:24:57 EDT
I wiped the partitions from a BIOS RAID1 array and started an i386 install using autopart and installing GNOME. I got this traceback when "installing bootloader." was on the installation progress screen

Package: anaconda-18.19
Architecture: i686
OS Release: Fedora release 18-Beta-TC6
Comment 18 Reartes Guillermo 2012-10-25 11:37:23 EDT
since started installing without swap nor a /boot, the installation obviously failed.

Addtionally i managed to install with a / and a 'ghost /'. It is possible to 'ghost' a partition, which
means that two mount points share a partition. (at least the for the UI they are two entries)


Package: anaconda-18.19
OS Release: Fedora release 18-Beta-TC6
Comment 19 Brian Lane 2012-10-25 13:37:28 EDT
Thomas, please describe exactly how you hit this error.

Tim, can you attach the anaconda-tb-* log?

Reartes, please open new bugs for different issues.
Comment 20 Reartes Guillermo 2012-10-25 14:13:52 EDT
> Reartes, please open new bugs for different issues.

I had no choice, i used ABRT. (and i was unaware of this bug-report).
As for the 'ghost' entries i will surely open another bug-report later.
Comment 21 David Lehman 2012-11-08 20:50:36 EST
I think I know what's going on here. We're allowing users to proceed with install even though there were errors when checking the storage configuration after leaving custom storage. I have a patch ready to test.
Comment 22 Fedora Update System 2012-11-09 19:55:31 EST
anaconda-18.28-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-17823/anaconda-18.28-1.fc18
Comment 23 Fedora Update System 2012-11-10 14:38:00 EST
Package anaconda-18.28-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.28-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17823/anaconda-18.28-1.fc18
then log in and leave karma (feedback).
Comment 24 Bastien Nocera 2012-11-15 04:35:05 EST
Installing the liveCD

Package: anaconda-18.29-1.fc18.x86_64
OS Release: Fedora release 18
Comment 25 Bastien Nocera 2012-11-15 06:27:03 EST
Looks like the .28 version didn't fix it, reopening.
Comment 26 Will Strang 2012-12-06 23:36:41 EST
Installing F18 beta from DVD  on a system with with 3 drives, with this layout:
/boot and swap on a 60GB SSD, / on a 305GB SATA disk, and /home on a 610GB SATA disk.
It sat in the installing phase for 30+ minutes, then got this error. CPU is a 3 core AMD Phenom.


Package: anaconda-18.29.2
OS Release: Fedora release 18-Beta
Comment 27 Brian Lane 2012-12-07 10:04:25 EST
Please retest with smoke4 from here - https://dl.fedoraproject.org/pub/alt/qa/20121205_f18-smoke4/
Comment 28 Flavio Leitner 2012-12-07 12:29:50 EST
I believe the bug happens due to my partition scheme.
I just need to install a fresh F18 Beta to reproduce it.


Package: anaconda-18.29.2
OS Release: Fedora release 18-Beta
Comment 29 Flavio Leitner 2012-12-10 16:50:39 EST
I tried smoke4, but it didn't start X correctly. It starts the graphical interface but remains with the busy mouse pointer forever.

I just tried smoke5, but after had selected the '/' (53GB), '/boot' (2GB) and swap (17GB) in the custom partitioning, it still complains about 'Error checking storage configuration' after had clicked at 'Finish Partitioning' button.

Any ideas?
Comment 30 Flavio Leitner 2012-12-10 19:29:16 EST
Ok, managed to install smoke5 on the same system and the grub is installed.
However, in the next boot it shows:
-----8<----
GRUB loading..
Welcome to GRUB!

error: file '/grub2/i386-pc/normal.mod' not found.
Entering rescue mode...
grub rescue> _
-----8<----

the directory grub2/ has themes/ only and nothing else.

So basically there is no more that backtrace, but it still doesn't succeed.

Running:
# grub2-install --target=i386-pc --recheck --debug /dev/sda

puts all files there, but fails saying:
warning: disk isn't LDM.
warning: Embedding is not possible. GRUB can only be installed in this setup by using blocklists. However, blocklists are UNRELIABLE and their use is discouraged.
Error: will not proceed with blocklists.

The above restores the grub in MBR. But still fails due to the lack of grub.cfg.
The following fixed it:
# grub-mkconfig -o /boot/grub/grub.cfg

Let me know if you need additional information.
Comment 31 Flavio Leitner 2012-12-18 08:37:49 EST
Ok, I think the bug I am seeing now is actually this one:
bz#831493 - Installing FC17 to system with Windows 7 with mirrored dynamic disks renders system unbootable.

As the original backtrace doesn't show up with smoke5, I think we can close this one.
Comment 32 Ozan Çağlayan 2012-12-18 11:39:26 EST
It happened at 'Installing bootloader' step.

Package: anaconda-18.29.2-1.fc18.x86_64
OS Release: Fedora release 18
Comment 33 Brian Lane 2012-12-18 16:37:21 EST
Thomas, can you re-test with smoke7?
Comment 34 Thomas Woerner 2012-12-19 09:48:19 EST
anaconda does not allow to proceed with installation with root > 2T and no extra /boot now. Therefore I can not test this.
Comment 35 Ozan Çağlayan 2012-12-19 13:52:47 EST
As a sidenote, the system on which I was doing the installation had an 250GB HDD on /dev/sdb, not > 2T.
Comment 36 Brian Lane 2012-12-19 14:00:33 EST
Ozan,

Can you give it a try with smoke8? The version you are using (from the Beta) is quite old.

https://dl.fedoraproject.org/pub/alt/qa/20121218_f18-smoke8/
Comment 37 J.A. Watson 2012-12-19 15:31:42 EST
Normal Anaconda install, with a single file system, Traditional Partition (not LVM).  Everything proceeds through software installation and post-installation procedures normally until Bootloader installation, then anaconda crashes.

This is a somewhat unusual system with a large number of partitions.  MS-DOS disk label, three primary partitions, one Extended partition, eleven Logical Partitions within the Extended.

jw


Package: anaconda-18.37.3-1.fc18.x86_64
OS Release: Fedora release 18
Comment 38 J.A. Watson 2013-02-14 04:19:38 EST
Regarding my system which contributed to this problem, I have just come across a potentially significant additional information.  I have been working around this problem on one system ever since this report was filed.  I recently found that although openSuSE 12.3 would install on the same system, it was not possible to boot Windows from that installation.  On investigating I found that the grub2 config file was very confused about the partition type - it was trying to treat the Windows 7 partition as an LVM partition.  When I manually edited the grub config file, and changed it to an msdos partition, the Windows boot succeeded.

Based on this I suspect that anaconda might have been getting confused by an invalid or corrupt disk label or partition label, and this was causing it to crash.  Although this is apparently a problem with this specific computer, or its disk drive, I still don't think this kind of problem should cause anaconda to crash...

Thanks,

jw
Comment 39 Brian Lane 2013-04-01 12:36:37 EDT
I'm going to close this one since it seems to be either fixed, or a different bug.

If you see problems with f19 please open a new bug with logs.

Note You need to log in before you can comment on or make changes to this bug.