Bug 868953 - Regression: libreoffice calc can't open HTML documents from "Open" dialog
Regression: libreoffice calc can't open HTML documents from "Open" dialog
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Eike Rathke
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-22 10:34 EDT by Martin Wilck
Modified: 2013-07-11 22:15 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-18 21:29:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot of open dialog (41.78 KB, image/png)
2012-10-22 10:34 EDT, Martin Wilck
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 45084 None None None 2012-10-23 11:36:39 EDT

  None (edit)
Description Martin Wilck 2012-10-22 10:34:13 EDT
Created attachment 631577 [details]
screenshot of open dialog

Description of problem:
In libreoffice 3.5.7.2, it's impossible to open HTML documents containing tables with oocalc. This worked nicely with libreoffice-calc-3.4.6.2-1.fc16.x86_64.

Version-Release number of selected component (if applicable):
libreoffice-calc-3.5.7.2-2.fc17.x86_64

How reproducible:
always

Steps to Reproduce:
1. create HTML document with a table

cat >test.html <<EOF
<html>
  <body>
    <table>
      <tr><td>one</td><td>two</td><td>three</td><td>four</td></tr>
      <tr><td>1</td><td>2</td><td>3</td><td>4</td></tr>
    </table>
  </body>
</html>
EOF

2. Click "Open", select the HTML document
3. Select file type "HTML Document - OpenOffice Calc" (see attached sceen shot)
  
Actual results:
File opens in LO Writer

Expected results:
File opens in LO Calc

Additional info:
Strangely, there are now 2 controls for the file type in the open dialog (there used to be only 1 in earlier versions).

I played around with the settings, but no matter what I did, the document would always open in Writer, not Calc.
Comment 1 Martin Wilck 2012-10-22 10:44:56 EDT
The test file can be opened in Calc from the command line by running "oocalc test.html" directly. So the problem seems to be in the "Open" dialog only.
Comment 2 David Tardon 2012-10-23 02:34:38 EDT
It does not work with the stock file dialog either, so it is not a problem of the Gtk dialog. It works in 3.6 .
Comment 3 Eike Rathke 2012-10-23 05:33:29 EDT
This rings a bell with me, it's fixed in upstream, now let's find the patch..
Comment 6 Eike Rathke 2012-10-25 07:20:55 EDT
f17-updates-candidate http://koji.fedoraproject.org/koji/buildinfo?buildID=362054
Comment 7 Fedora Update System 2012-11-12 15:07:59 EST
libreoffice-3.5.7.2-6.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libreoffice-3.5.7.2-6.fc17
Comment 8 Fedora Update System 2012-11-14 21:40:27 EST
Package libreoffice-3.5.7.2-6.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreoffice-3.5.7.2-6.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-18238/libreoffice-3.5.7.2-6.fc17
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2012-11-18 21:29:43 EST
libreoffice-3.5.7.2-6.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.