Bug 868958 - Win 7 64 Client: Connecting to VM sometimes prompts for a password
Win 7 64 Client: Connecting to VM sometimes prompts for a password
Status: CLOSED DUPLICATE of bug 857504
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mingw-virt-viewer (Show other bugs)
3.1.0
x86_64 Windows
medium Severity unspecified
: ---
: ---
Assigned To: Marc-Andre Lureau
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-22 10:47 EDT by Vimal Patel
Modified: 2012-10-22 10:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-22 10:53:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of Authentication Required Dialog (327.81 KB, image/png)
2012-10-22 10:47 EDT, Vimal Patel
no flags Details

  None (edit)
Description Vimal Patel 2012-10-22 10:47:29 EDT
Created attachment 631581 [details]
Screenshot of Authentication Required Dialog

Description of problem:
There are times when connecting to a VM, the remote-viewer windows also brings up a dialog that states Authentication required, where Username is blank and prompts for a password.  There is no password on the VM and closing the window and reconnecting to the console brings the display of the VM.

I have seen it be more reproducible by making a remote-viewer connection and closing it before the display is brought up and then trying to bring up the remote-viewer window again.  But I have also seen it come up just connecting to it for the first time in a browser session.

*Tested on Win 7 64 client, I've seen it a occur 4 or 5 times.  I also tested on a Win 7 32 bit client, but never saw it on that client.

Version-Release number of selected component (if applicable):
RHEVM 3.1, si20
Win7 Client:
remote-viewer: 0.5.3
USB Clerk

Guest: RHEL 6.3 64
rhevm-guest-agent-1.0.5-3.el6ev.x86_64
spice-vdagent-0.8.1-3.el6.x86_64
xorg-x11-drv-qxl-0.0.14-13.el6_2.x86_64 

How reproducible:
I've seen it 3 or 4 times during testing (connecting to it around 50 times)

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Password prompt

Expected results:
No password prompt, just have a display to the VM brought up.

Additional info:
Comment 1 David Jaša 2012-10-22 10:53:36 EDT

*** This bug has been marked as a duplicate of bug 857504 ***

Note You need to log in before you can comment on or make changes to this bug.