Bug 868972 - CPU topology is missing in capabilities XML when libvirt fails to detect host CPU model
CPU topology is missing in capabilities XML when libvirt fails to detect host...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Jiri Denemark
Virtualization Bugs
: TestBlocker, ZStream
Depends On: 866999 876475
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-22 11:27 EDT by Chris Pelland
Modified: 2012-11-22 04:40 EST (History)
15 users (show)

See Also:
Fixed In Version: libvirt-0.9.10-21.el6_3.6
Doc Type: Bug Fix
Doc Text:
Cause: When libvirt could not find a suitable CPU model for host CPU, it would not provide CPU topology in host capabilities even though the topology was detected correctly. Consequence: Applications that want to examine host CPU topology but otherwise do not care about CPU model could not see the topology in host capabilities. Fix: Host capabilities XML now contains host CPU topology even if host CPU model is unknown. Result: Applications can rely on host CPU topology to always be present in capabilities XML unless detecting the topology itself failed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-22 04:40:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Pelland 2012-10-22 11:27:07 EDT
This bug has been copied from bug #866999 and has been proposed
to be backported to 6.3 z-stream (EUS).
Comment 7 Rami Vaknin 2012-11-14 11:23:44 EST
Verified on libvirt-0.9.10-21.el6_3.6.x86_64 (rhel6.3).

The VM's xml given by "virsh capabilities" now contains the cpu topology:

<capabilities>

  <host>
    <uuid>067f8a8b-5ab3-413c-aa37-945854bf102e</uuid>
    <cpu>
      <arch>x86_64</arch>
      <topology sockets='1' cores='1' threads='1'/>
    </cpu>
    <power_management>
      <suspend_disk/>
    </power_management>
    <migration_features>
      <live/>
      <uri_transports>
        <uri_transport>tcp</uri_transport>
      </uri_transports>
    </migration_features>
    <topology>
      <cells num='1'>
        <cell id='0'>
          <cpus num='1'>
            <cpu id='0'/>
          </cpus>
        </cell>
      </cells>
    </topology>
    <secmodel>
      <model>selinux</model>
      <doi>0</doi>
    </secmodel>
  </host>

</capabilities>
Comment 9 errata-xmlrpc 2012-11-22 04:40:03 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1484.html

Note You need to log in before you can comment on or make changes to this bug.