Bug 869003 - Merging leg back into raid1 does not work: no data are actually merged
Merging leg back into raid1 does not work: no data are actually merged
Status: CLOSED DUPLICATE of bug 870246
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2 (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Jonathan Earl Brassow
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-22 14:04 EDT by Marian Csontos
Modified: 2012-11-08 13:41 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-08 13:41:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed change to test suite to reproduce the bug (1.01 KB, text/plain)
2012-10-22 14:04 EDT, Marian Csontos
no flags Details
output of lvconvert --merge -vvvv (189.56 KB, text/plain)
2012-10-22 14:09 EDT, Marian Csontos
no flags Details

  None (edit)
Description Marian Csontos 2012-10-22 14:04:40 EDT
Created attachment 631665 [details]
Proposed change to test suite to reproduce the bug

Description of problem:
Merging leg back into raid1 does not work: raid claims to be 100% in sync, while no data are written to the merged leg.

Setting severity to high due to risk of data corruption.

Version-Release number of selected component (if applicable):
lvm2-2.02.98-2.x86_64.el6
kernel-2.6.32-335.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
- updating the test suite with provided patch _should_ raise an error
  
Actual results:
- legs show differences.

Expected results:
- legs should be the same

Additional info:
Comment 1 Marian Csontos 2012-10-22 14:09:55 EDT
Created attachment 631668 [details]
output of lvconvert --merge -vvvv
Comment 3 Marian Csontos 2012-11-08 13:41:11 EST

*** This bug has been marked as a duplicate of bug 870246 ***

Note You need to log in before you can comment on or make changes to this bug.