Bug 869042 - Udisks2 keeps spitting out useless info
Udisks2 keeps spitting out useless info
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: udisks2 (Show other bugs)
18
x86_64 Unspecified
unspecified Severity low
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-22 17:02 EDT by Mark van Rossum
Modified: 2013-03-05 23:09 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-22 17:07:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark van Rossum 2012-10-22 17:02:09 EDT
Description of problem:

Since upgrading to FC18, my terminal occasionally keeps spitting out messages
like:

"/org/freedesktop/UDisks2/drives/INTEL_SSDSA2CW300G3_CVPR1304019T300EGN" 's interface "org.freedesktop.UDisks2.Drive.Ata" changed props: 
	 modified: "SmartUpdated" : QVariant(qulonglong, 1350938558) 

which is somewhat annoying, as the SMART status is just fine.

Editing 
 /etc/dbus-1/system.d/org.freedesktop.UDisks2.conf
to deny it output seems to fix it.


Version-Release number of selected component (if applicable):
udisks2-2.0.0-1.fc18.x86_64
Comment 1 David Zeuthen 2012-10-22 17:07:52 EDT
Seems to be a problem with a Qt application on your system (the QVariant is giving that away). Since udisks2 does not use Qt, it's not a udisks2 problem so I'm closing it CANTFIX since there is nothing to fix.

My guess is that you have a buggy Qt app listening to D-Bus signals from udisks2. Feel free to reopen and reassign if you figure out what application it is.

Note You need to log in before you can comment on or make changes to this bug.